M109 Rider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
516 Posts
Discussion Starter · #1 ·
Arrrrrggg! . . . I just finished sending back my 2nd drive shaft cover. I purchased the Suzuki cover because it was supposedly the best quality cover out there (chrome steel and held on with clamps, not tape). However, there was just no way these covers would fit tight to the shaft without large gaps at one end or the other. I even had the dealer try and still no luck. All we did was end up scratching the black paint on the shaft all to rat sh#t. :mad:

I've seen lots of pics on this forum with shaft covers that fit great. I own a '09. Is it possible there was a slight change to the shape of the drive shaft housing for that year causing these covers to not fit. I'm at a loss. Any feed-back would be appreciated.
 

·
Registered
Joined
·
5,918 Posts
I have a Suzuki shaft cover on my 06, it was bought in 07. It fits real well, as does the one on my friend Sam West's 06. Only thing I can think of is that some bonehead packaged a bunch of shaft covers for other Zukes in a M109R package.:dontknow:
 

·
Registered
Joined
·
2,013 Posts
I just put one on my bike this afternoon. At first, I thought it wasn't gonna fit because it won't go over the bolts. And after a couple of different ways(shubbing, kicking and cursing), I made it fit. All I had to do was to slide the shaft cover in and latched on to the upper bolt and snapped the bottom lip over the bottom bolt. Then, slid it in to place. Done.
 

·
Registered
Joined
·
1,478 Posts
I bought the Zuki cover when I picked up my '08. Perfect fit. As far as I know, no changes to the swingarm that I know of. :dontknow:
 

·
Registered
Joined
·
516 Posts
Discussion Starter · #5 ·
Well, here's an update. Received my 3rd different OEM shaft cover today and it slipped on like a glove! I ordered from a different supplier (Oneida) this time. I'm beginning to suspect that there is a batch of these things out there that just don't fit as there has been a couple of others on the forum who have had the same problem. Anyways, a bit more bling is always good!
 

·
Registered
Joined
·
216 Posts
Shaftcover

Mine has NEVER fit as good as I'd like it to--always some kind of gap somewhere. Must be the luck of the draw on these things. Glad yours fits well. In addition, after long rides, the vibration and jolts from the road usually make the gap really noticeable around the bolts. :edit: Just be sure to check it from time to time--you may have to readjust it on the regular!!!
 
1 - 6 of 6 Posts
Top