M109 Rider Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
Any of you guys any where near Dayton willing to help me out? I found a coolant leak a few weeks back, played around with the bike a bit and no more leak. Today, I ride home for lunch and just happen to glance down and there's another coolant leak, this time, in a different area! :dontknow:


Any of you guys that know what you are doing, please help a new 9er out!! I will ride the bike to wherever you are, whenever you name a time.

Thanks in advance. :bigthumbsup:
 

·
Registered
Joined
·
204 Posts
Might as well check all the clamps while your at it. Mine was leaking on the left side, looked like wax after it dried near the shifter. There is a 3way connector near the frame rail under the tank, that is where mine was coming from.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #16 ·
So it looks like I'm going to have to be brave and take the tank off as well as a few more pieces?
 

·
Registered
Joined
·
3,740 Posts
So it looks like I'm going to have to be brave and take the tank off as well as a few more pieces?
If you can get a friend to help, taking off those pieces aren't really that hard! I only say that because I am no mechanic myself and I don't like getting in their all the time but everything comes off pretty easily. The tank for example is only held on by 1 bolt! Just get a friend to help you disconnect the cables and lines and the other stuff is just clips and screws...

Good luck!
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #18 ·
If you can get a friend to help, taking off those pieces aren't really that hard! I only say that because I am no mechanic myself and I don't like getting in their all the time but everything comes off pretty easily. The tank for example is only held on by 1 bolt! Just get a friend to help you disconnect the cables and lines and the other stuff is just clips and screws...

Good luck!
Thanks, I'll grab someone to help out for a bit. Its going to be a problem getting someone to be at my house at 7:30 Sat morning though, lol. Gotta get it done so I can ride all day!
 

·
Registered
Joined
·
550 Posts
Might as well check all the clamps while your at it. Mine was leaking on the left side, looked like wax after it dried near the shifter. There is a 3way connector near the frame rail under the tank, that is where mine was coming from.
I thought I had a leak in the radiator maybe from the front tire throwing up some gravel... :eek: I had green spots on my chrome on the L side and could smell coolant...low and behold... loose clamps. Changed the coolant out while I was in there... The stock coolant looked almost pure, dark green and thick.
 
1 - 19 of 19 Posts
Top