M109 Rider Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter · #1 ·
Took my bike to Stubbs Southwest here in Houston yesterday. Guys did the first service with Amsoil in the diff and Suzuki 20/50 in the motor with the Zuki filter. They knew about the oil issue and I was VERY specific with them about showing me the empty containers when I picked her up. Also had them tighten the clamp on the coolant hose just in case (was not leaking , just precautionary). They have seen the oiling prob several times and were very aware of what it entails.

When I picked her up a couple of hours later (speedy service and ONLY $120 for the first service with Amsoil in the diff!) They followed directions to the tee and showed me three empty quarts and gave me a fourth with half gone. They also gave me the remaining half bottle of Amsoil diff gear fluid. The tech that worked on it is very experienced and has done many of these previously.

Well, I get home and there is the dreaded oil on my left leg, seat, side panel and motor covers. Honestly I was very suprised given it appeared they put the correct amount in (Zuki specifies 3.8 qts with filter). I proceeded to pick up another left hand filter from them today to replace the oiled up one - They were VERY good about wanting to do whatever they could to fix the prob and gave me the replacement filter. I wanted to do it myself since I am going on the Houston/DFW meet and greet ride tommorrow.

Anyway , what a pain.....guess I will be draining off a bit of fluid and checking and rechecking tonight as well as cleaning the bike up....... :(
 

·
Registered
Joined
·
118 Posts
Check the back of your left side air box, there is a re-circulating tube there that may not be connected right and could cause it, too. (They would have had to remove it to tighten the coolant hose and might not have re-connected it right).

BTW, Zuk recommends 3.6 qt - not 3.8  (1 qt = 946ml; 3.6qt x 946 = 3405ml)...

J
 
G

·
Shriker said:
Took my bike to Stubbs Southwest here in Houston yesterday. Guys did the first service with Amsoil in the diff and Suzuki 20/50 in the motor with the Zuki filter. They knew about the oil issue and I was VERY specific with them about showing me the empty containers when I picked her up. Also had them tighten the clamp on the coolant hose just in case (was not leaking , just precautionary).  They have seen the oiling prob several times and were very aware of what it entails.

When I picked her up a couple of hours later (speedy service and ONLY $120 for the first service with Amsoil in the diff!) They followed directions to the tee and showed me three empty quarts and gave me a fourth with half gone. They also gave me the remaining half bottle of Amsoil diff gear fluid. The tech that worked on it is very experienced and has done many of these previously.

Well, I get home and there is the dreaded oil on my left leg, seat, side panel and motor covers. Honestly I was very suprised given it appeared they put the correct amount in (Zuki specifies 3.8 qts with filter).  I proceeded to pick up another left hand filter from them today to replace the oiled up one - They were VERY good about wanting to do whatever they could to fix the prob and gave me the replacement filter. I wanted to do it myself since I am going on the Houston/DFW meet and greet ride tommorrow.

Anyway , what a pain.....guess I will be draining off a bit of fluid and checking and rechecking tonight as well as cleaning the bike up.......  :(
Wrong 3600 ML. do the Math. Not 3.8 quarts.
 

·
Registered
Joined
·
118 Posts
raw_taz said:
Wrong 3600 ML. do the Math. Not 3.8 quarts.
Gee, Taz... who's WRONG??? 3600ml??? Guess you just wanted to throw your mighty weight around and try to slam another poster ::) Apparently you didn't see my post just above yours, so let's restate it here...

jcopley said:
BTW, Zuk recommends 3.6 qt - not 3.8Â (1 qt = 946ml; 3.6qt x 946 = 3405ml)...
:joke:

J
 
G

·
jcopley said:
Gee, Taz... who's WRONG??? 3600ml??? Guess you just wanted to throw your mighty weight around and try to slam another poster ::) Apparently you didn't see my post just above yours, so let's restate it here...

:joke:

J
I did not see your post. Sorry about that. There have been enough posts on the oil thing and the whole math problem.
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #7 ·
Thanks for the correction guys , I removed a few ounces and cleaned the airbox out and she has been perfect since , put 350 miles on her today with no probs.
 

·
Registered
Joined
·
572 Posts
Glad it worked good the rest of the day :)

It was a funny sight today am sure... seeing us out there working on bikes...

There was a Harley guy riding by today when we were in Huntsville... was funny the look he gave us as he rode by... guess he felt better that we work on our bikes at times too, LOL

:doorag:
 
G

·
Shriker said:
Thanks for the correction guys , I removed a few ounces and cleaned the airbox out and she has been perfect since , put 350 miles on her today with no probs.
Sorry about the flaming, I was a little peeved last night about the Clutch posts all six of them, and this oil thing has been beaten to a pulp. I am glad you got it worked out and all is well.

Shinny side up, ride safe.

TAZ
 

·
Registered
Joined
·
3,121 Posts
I just had this issue for the first time today. My oil had been done twice by the dealer correctly, and I have checked it.
I have been riding this oil over 2000 miles without an issue till today????
All I can think is that I was keeping it to hogh in the power band for too long uip the twisty mountain road I was on.

Sledzep
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #11 ·
I absolutely love this bike but it is a bit rediculous the proceedure and inconsistency you get trying to just get the oil level correct and maintain it......surely they could have engineered that a bit better. My only complaint with this otherwise stellar muscle cruiser IMO.....

At least it easily gets rid of an overfill , not allowing it to be more harmful.....and its relatively easy to clean up as long as you have a spare filter laying around.
 
1 - 13 of 13 Posts
Top