M109 Rider Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
Hi All

Bought my pride and joy and thought I'd have her dropped before delivery. I purchased 2" links from Brunos Bike Parts. I was sent out the links and the shop is on the pohone now sawing the holes in the links are too small fro the sleeve and bearings to fit into. BUT The bolt fits straight through no probs.

I don't want them to just install them using the bolt only as surely this will just grind itself away eventually :dontknow:

Has anyone else had this problem? The dealer says the front and rear holes on the bones are the same size, were as the pics from this thread show the hole on the right to be larger...

http://www.m109riders.com/forums/showthread.php?t=100957

What do I do? Get a refund from Bruno's? Or tell them to drill out the new bones and slide the old sleeve and bearings and re-use?
 

·
Banned
Joined
·
15,179 Posts
Hi All

Bought my pride and joy and thought I'd have her dropped before delivery. I purchased 2" links from Brunos Bike Parts. I was sent out the links and the shop is on the pohone now sawing the holes in the links are too small fro the sleeve and bearings to fit into. BUT The bolt fits straight through no probs.

I don't want them to just install them using the bolt only as surely this will just grind itself away eventually :dontknow:

Has anyone else had this problem? The dealer says the front and rear holes on the bones are the same size, were as the pics from this thread show the hole on the right to be larger...

http://www.m109riders.com/forums/showthread.php?t=100957

What do I do? Get a refund from Bruno's? Or tell them to drill out the new bones and slide the old sleeve and bearings and re-use?
You dont use the bearings with anything bigger then 1.5" bones. 2 " ya just put a little good grease on the bolt, i thought the same when I bought mine. It is normal not to use the bearing.

Edit, is this the first time that shop worked on a 9? woooooooo
 

·
Registered
Joined
·
108 Posts
s.o.s.

Idid mine last weekend. no bearings required, {they didnt need them}
Insta

ll using plenty of grease. ,, itll be fine .
I was paniking too ,,, its all good brother:bigthumbsup:
 

·
Registered
Joined
·
838 Posts
I've got a different brand of bones, same issue though. All I did was greased the holes really good and installed. Got (I'd say) over 4k on them. Have not had any issues what so ever.
Install, ride and enjoy your bikes new stance. :bigthumbsup:
 

·
Registered
Joined
·
2,313 Posts
:agree:

It is a non-issue. That is how they are made and they work fine that way.

By the way, nice find on Bruno's.

He is a good guy and lives about 3 miles from me.

He is also a member here even though he no longer owns a 9.
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #6 ·
Phew!! Thanks for that!

Unfortunately they wasted 40 minutes scratching their heads before calling me so its now closing time :'(

So instead of picking it up tomorrow (Saturday) morning like planned I have to collect Monday night after work. Its forecast for 87 degrees and 88 on Sunday so It would have been a perfect two days to get to know the bike.

Oh well
 

·
Registered
Joined
·
838 Posts
Phew!! Thanks for that!

Unfortunately they wasted 40 minutes scratching their heads before calling me so its now closing time :'(

So instead of picking it up tomorrow (Saturday) morning like planned I have to collect Monday night after work. Its forecast for 87 degrees and 88 on Sunday so It would have been a perfect two days to get to know the bike.

Oh well
tell them youll pick it up first thing sat and you'll do the rest. There is a how to on here. Easy Peasy
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #8 ·
Wish it was that easy... they are yet to put the rear wheel and shaft back in after I had them remove them to get mirror-polished...

Monday noon it is. Everyone at work is actually glad because I'll pick it up during my lunch-break and have to bring it back so they all want to have a look
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #11 ·
Nah mate, they didn't :p Bit surprising at their lack of knowledge though. I went to them because they are the biggest Suzuki dealer in town...

I think once I get her home I'll take her to a smaller dealer for servicing and any warranty issues as the service may be better
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #12 ·
BTW, I've got the 2.25" bones (no bearings) and have 20,000+ miles on them......no issues. :bigthumbsup:
Excellent :bigthumbsup: Just what I want to hear!

I'll bring my laptop in to work Monday morning and I'll swing past first thing and show them this thread!
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,877 Posts
I pulled my bones off to lube them after they had been on around 15,000 miles, and the hole in them was out of round by less than .003". They don't really move that much, but all the movement is just a little front and back. They mostly support the load so the bearings and/or bushings really aren't needed.
 
1 - 13 of 13 Posts
Top