M109 Rider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
I know the Tre from Trackday is the same one for the M90 as it is for the 109. I was trying to hook mine up today and believe I may have hooked it to the wrong connector.

I see all the posts for the 109 about the connector on the left being the wrong one but, It is the only one I can find. I was wondering if the connectors on the 90 may be in a different spot?

The Gear indicator is working fine plugged into the left side plug but, The Tre does'nt feel like it is doing anything.

If you have a better explenation on where to find the correct connector please let me know. Thanks
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #3 ·
The connector I found that is working for the gear display is directly behind the connector for the ignition switch on the left side.

As you stated there are no other connectors that would work with the tre, So this has got to be it. I am guessing the M90 is slightly different from the 109.

I will ride with it this weekend then post review and install pictures up here.
 

·
Registered
Joined
·
102 Posts
It does appear to be on the LEFT side on the M90s according to the online parts fiche. I think the M109 is the only one that is on the RIGHT side.

Most bikes, like the GSXR and SV models, also have the connector on the LEFT.

The Gear Emulator(ATRE) may not have the same effects on the M90 as the M109.

darrin
TrackDayElectronics.com
 
1 - 4 of 4 Posts
Top