M109 Rider Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 · (Edited)
hey guys ever had that happen to you? (throttle sticking )
the wife and i went for a ride sunday put about 200 miles on ,just cruisin around .anyway my bike was just fine and i come off the highway in to town and the throttle wouldnt idle down . it is allways idled at 1000 or 1100 ,well we slowed down for a stop light and it wouldnt slow down any more than 2300 rpm ...so pulled over at the closest stop and fiddled with the throttle cables adjust, revved it up two or three times .... nothin. then shut it off, startin to get a little ticked off now. Let it sit for about 2 min. then i started it and it was fine just like nothin happened???? it was fine the rest of the day ??? so what do you guys think ?? never had any problems at all,:dontknow::dontknow: have about three weeks left on my warrentey ???
 

·
Registered
Joined
·
4,743 Posts
do you have a jsd3m? :dontknow:
Winner! Mine has started doing that...That's why I've quit recommending the JSD's and now recommend the Gipros:bigthumbsup:

If it's doing it while your driving...Get it off! Most do it right at startup. Then turn it of and back on they seem to reset.;)
 

·
Registered
Joined
·
4,743 Posts
yes i do have a jsd3m do you think that could be it ??if so it will be off tomorrow??
There's a bunch of threads on here about them. I knew what this thread was about before I even opened it. I'm sure BicuitP did too.:bigthumbsup:
 

·
Registered
Joined
·
2,313 Posts
Mine did it once when it was bone stock and once since extensive mods.

I has not been a consistent problem and ends if you just turn it of and back on again, so the computer can do a reboot, so I have not been concerned about it too much.
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #7 ·
so.. thats the cure ? get rid of the atre and get a gipro,kind of like the idea of the gear indocater..
 

·
Registered
Joined
·
1,270 Posts
before you remove all of your mods, make sure that you waited for the starting "boot up" to complete. If you start it before the sequence completes, this can happen. Make sure you turn the key on and wait the 5-10 seconds until all components have been reset and then start it.
 

·
Registered
Joined
·
1,764 Posts
personally, i still have my jsd. it has only done this a time or two and never while i was riding. it has happened at start-up only. but i have also seen lots of posts about this. one day when i grow up i will get a gi-pro.:joke:
 

·
Registered
Joined
·
3,740 Posts
In the 1.5 years I've had my JSD It's done the high idle things twice, both times after starting the bike up after shutting it down for a few minutes (like filling up gas)

Started the bike up again and it was fine...
 

·
Registered
Joined
·
4,743 Posts
Here's a repost by Seapup on the start up issue. The thing about stuck high RPMs while driving was attributed to the TRE. I'm looking for some of the older posts about the stuck throttle.

http://www.m109riders.com/forums/showthread.php?t=130543&highlight=JSD+High+Idle
Here's an article about Vacuum lines and their relation to the high idle. Have you had the tank off lately?
http://www.m109riders.com/forums/showthread.php?t=80660&highlight=High+Idle+driving

The JSD gives a 1,000-1100 idle regularly too. The GiPro doesn't do that from what I understand. In some of the posts You can hear the confidence in the Gipros. If I had the money I would switch to the GiPro but right now there are other priorities....like risers new cables... Eventually I'll have the Girpro.
 

·
Registered
Joined
·
1,918 Posts
Do you have throttle lock dev on it.
 
1 - 15 of 15 Posts
Top