M109 Rider Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
Squeaky FI engaging.... Anyone else have this going on??

When I first got the bike it was a nice and smooth sound... Now when I go to turn it on... I hear a few squeaks as the injection process gets ready for fire up.
 

·
Registered
Joined
·
1,637 Posts
As far as I can tell the noise you are hearing is the S.E.T valve resetting when you tutn the key on...............and mine also has done it from day one :)
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #5 ·
For the first week or two it was just a nice smooth sound as they set up. Now it squeaks. No harm to the FI of course, just an annoyance.
Then about 4-5 weeks ago, I received a FI display error... I remember the day, I shot down the highway at 120'ish for a while then took an exit and went to a store right off the exit. When I came out a few minutes later the bike wouldn't start... It cranked, but didn't start. And in the bright sun I happen to notice the FI error on the display. Then I remembered that I never heard any sound of the FI setting up. So I sat there and toggled the Power On/Off switch and key for a minute tops and all the sudden it engaged. Not sure if it was related to the fast sprint and instant shut-off? But it's never done it since.

Anyway... I was curious if was just my bike... Because I was going to dig into it and WD40/Lube the area... But I thought I'd toss it out and see if others had it...
 
G

·
I have had the squeak since day 1 it is the set valve testing.

You may have a problem with the S.E.T. Valve cable, there is another post on here about a guy who had that problem. If the dealer is close they should be able to read the ECM codes to tell you what the error was, since the bike is under warranty, I would do that first.

RAW_Taz
 
G

·
What value does disabling the SET offer? It is there for a reason. You will see when the final testing is done that the stock pipes with that stupid SET will deliver more HP and torque with the Thuner Air kit then any of the 600.00 dollar sets of noise makers.

There is no reason to disable the SET it is there for low end torque and there is not a manufacture of after market pipes that has that figured out as of yet.

Take your bike to the dealer and have them pull the ecm codes to see what the FI error was. This Hammer vs Computer mentality is crazy.

RAW_TAZ
 

·
Registered
Joined
·
1,102 Posts
well as you know the bike is twitchy down low. for me it has smoothed things out and ill gaurantee there is more hp there. i have disabled the s.e.t. and fi light also. try it, it's easy. takes 10mins.  :bigthumbsup:
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #12 ·
raw_taz said:
What value does disabling the SET offer? It is there for a reason. You will see when the final testing is done that the stock pipes with that stupid SET will deliver more HP and torque with the Thuner Air kit then any of the 600.00 dollar sets of noise makers.

There is no reason to disable the SET it is there for low end torque and there is not a manufacture of after market pipes that has that figured out as of yet.

Take your bike to the dealer and have them pull the ecm codes to see what the FI error was. This Hammer vs Computer mentality is crazy.

RAW_TAZ
So even if there's no present error you're saying the dealer cans still pull a 'history' report or something...
 

·
Registered
Joined
·
1,102 Posts
raw_taz said:
What value does disabling the SET offer? It is there for a reason. You will see when the final testing is done that the stock pipes with that stupid SET will deliver more HP and torque with the Thuner Air kit then any of the 600.00 dollar sets of noise makers.

There is no reason to disable the SET it is there for low end torque and there is not a manufacture of after market pipes that has that figured out as of yet.

Take your bike to the dealer and have them pull the ecm codes to see what the FI error was. This Hammer vs Computer mentality is crazy.

RAW_TAZ
taz, i also wasnt saying disable the set because he had a FI code. by all means he should have that looked at. with mine disabled i did the mod to trick the ecu into thinking its still hooked up. so if i get a FI code it will be for different reasons, other than the set.
 

·
Registered
Joined
·
1,102 Posts
....for low end torque. i believe the bike is smoother and performs better with it disabled. i just want jeffw's reasoning for saying leave it alone.  :bigthumbsup:
 
G

·
bad109 said:
taz, i also wasnt saying disable the set because he had a FI code. by all means he should have that looked at. with mine disabled i did the mod to trick the ecu into thinking its still hooked up. so if i get a FI code it will be for different reasons, other than the set.
Dude your Avatar worries me.

Anyway, the SET continually works with the motor to mangage the power curve that Suzuki has engineered, I understand you have a seat of the pants feeling about this you have shown any proof, (i.e. Dyno testing) to remove the SET you may have actually lowered you HP by 10 or 20 or who knows what by doing this.

I don't think it is prudent to tell newbies or guys who are having a problem to remove a intregal part of this bike. Nothing personal I just feel that you must prove your point before you spout off.

TAZ
 
G

·
WIZARD said:
Squeaky FI engaging.... Anyone else have this going on??

When I first got the bike it was a nice and smooth sound... Now when I go to turn it on... I hear a few squeaks as the injection process gets ready for fire up.
I know for a fact that fuel-injection doesn't squeak. Maybe SET. Look it up.
 
1 - 20 of 23 Posts
Top