M109 Rider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
I posted about a week ago about my speedometer sticking and got a couple of replies, but still having some issues. I pulled the sensor cleaned it off, did not fix the problem. I pulled speedometer face and needle, put a couple drops of wd-40 in the hole seemed to get better but still sticks a little and seem to hesitate on deceleration.(Trying to stay away from dealership) HELP :dontknow:
 

·
Banned
Joined
·
15,179 Posts
I would have to think you have a bad sensor under that side cover then. If the needle is free and clear. The needle moves from the electric pulse from the sensor. I am not sure but that makes sense to me LOL
 

·
Radio Active Member
Joined
·
27,669 Posts
Sounds to me like it is multimeter time and find out what's up since the normal fixes did not cure it.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
if my memory serves me you didn't say "stick" in your other thread. Sticking and erratic behavior are 2 different things. Have you gone through the resetting procedure?
Not sure what you mean, I've had the speedometer apart(face off and needle pulled ) cycled the key to set needle back to correct position after putting wd-40 in it???
 

·
Registered
Joined
·
147 Posts
manual

In the owners manual,as pointed out to me by some helpfull 109er on here, there is a reset procedure,might be worth a try.....
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #7 ·
to reset speedo,
1 press the adj button and turn on in ignition
2 press and hold the adj button for 3-5 sec
3 release the adj button and press the adj button twice within 1 sec

its what the book says
Have not done that, will try that asap. Thanks fro the info, I appreciate the help!!!
 

·
Registered
Joined
·
163 Posts
Not sure what you mean, I've had the speedometer apart(face off and needle pulled ) cycled the key to set needle back to correct position after putting wd-40 in it???
I hope the adding of a water dispersant to your speedo didn't hurt it. WD-40 is not a good lubricant. I would try maybe a dry graphite or a very small amount of air first then the dry graphite i would think the WD-40 would make it drag from the weight. This is just my experiance. Just be careful putting anything in a speedo. JMO:doorag:
 
1 - 8 of 8 Posts
Top