M109 Rider Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter · #1 ·
Anybody else have smudges on the inside of the clear spedo plastic ?. It looks like something is smeared on the upper area inside the plastic. I pointed it out to the dealer and they said they would take care of it at the 600 mile service.
 

·
Registered
Joined
·
209 Posts
I have this on mine too. Sence I'm not planning on taking mine back for service if anyone knows how to remove it let me know thanks
 

·
Registered
Joined
·
15 Posts
Mine has it also. I pulled it apart over the weekend to clean it but it appears to be perminate. Looks like someone wiped the inside of the lens with acetone or something similar. I called the dealer yesterday and ordered a new cover.
 
G

·
rangemaster84 said:
I have the same blemish it's a minor detail but I'd like to correct it none the less.
Anybody know if they are shipping OEM parts for the M yet or is everything on back order?
Pretty much everything's on backorder :verymad:.
 

·
Radio Active Member
Joined
·
27,699 Posts
Felix T Cat said:
Thanks, Mine is actually very easy to see. Now that I think about it, the smears really look like someone licked the inside of the cover..........

eeeeewwwwwwwwww
I'm sure they did not lick it, it must be there drool as the bike was taking shape going down the factory line. :a20:
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top