M109 Rider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Has anyone had any problems with their 109r yet? I have only had mine for 1 week and it has already been in the shop twice. The FI light keeps coming on. The first time the tech said it was an exhaust control module valve. He said the cable was never tighten good from delivery and setup. Then it came on again and it has been in the shop ever since. Go figure it goes in the shop on a beautiful weekend. Any info would be great.
 

·
M109Riders Founder
Joined
·
8,014 Posts
toneout said:
What's it in the shop for the second time?
Has anyone had any problems with their 109r yet? I have only had mine for 1 week and it has already been in the shop twice. The FI light keeps coming on. The first time the tech said it was an exhaust control module valve. He said the cable was never tighten good from delivery and setup. Then it came on again and it has been in the shop ever since. Go figure it goes in the shop on a beautiful weekend. Any info would be great.

Bummer :verymad:
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
my m109r is in the shop for replacing the exhaust control valve. It is faulty and they have to order a new one from the factory. It has been in the shop for a week and the part hasn't even been ordered because they say they can't find the order number from suzuki. Suzuki doesn't have the parts list for the bike in the dealership near me. The dealer said it could be weeks before they get the part. In the mean time it just sits in the shop. Very frustrated owner
 

·
Registered
Joined
·
74 Posts
shawnadair was it the valve itself or the electronics that open and close it. the module was bad on mine and they got a part from Canada in 5 days. It was making the fi light come on.
 
1 - 6 of 6 Posts
Top