M109 Rider Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
448 Posts
Discussion Starter · #1 ·
Ok so I got these on and there is a gap between the cap and the riser and I have torque them down and this is as close as I can get it is this the way they are??
 

·
Registered
Joined
·
2,313 Posts
Is the gap the same on the other side of the caps?


It is just the picture, or is there a gap between the risers and the bar?

It looks like the riser opening is not quite large enough for you bar to seat in there properly, but that could just be the odd things about chrome in pictures.
 

·
Registered
Joined
·
1,626 Posts
I have the same risers and the same problem, I have contacted the manufacturer about the issue and they are "checking into it" but have not heard back from them yet. I believe they made the caps for 1" bars instead of 1 1/4" bars! I do still ride it without any problems. ;)
 

·
Registered
Joined
·
448 Posts
Discussion Starter · #4 ·
No they are completely flush
I thought the same they are made for a smaller bar
 

·
Registered
Joined
·
448 Posts
Discussion Starter · #5 ·
Pic
 

·
Registered
Joined
·
448 Posts
Discussion Starter · #7 ·
Another one
 

·
Registered
Joined
·
448 Posts
Discussion Starter · #9 ·
Yana shiki
 

·
Registered
Joined
·
2,450 Posts
Do a search on my review/write up of these riders I did last year or so. Search for Yana Shiki, long write up with a lot of pics. Good luck on getting them to do anything---just not what they do.

Sent from my EVO using Tapatalk
 
1 - 12 of 12 Posts
Top