M109 Rider Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
I have a question for anyone and info to check out on the M. I had a rear brake squeak check the usual metallic pad to rotor remedies and found the floating brake system has play in it beyond design. The play I refer to is as you face your bike you will see the rings that join the two pieces of the rotor assembly, place your hand on the outer ring and push or pull the rotor right to left. I have a quarter inch of play!! I have taken the bike to dealer to show them and recommends not to ride the bike ( scared him to be exact) . They Looked for the rotor and the part is on backorder . They then contacted Suzuki rep. and says he had no knowledge of problem. I have the 601st model made in 06 the bike has 2013 miles one wheelie and eight burnouts, no off-roading or drops. I am mostly surprised at this problem at this time I hope that this info will help any of my fellow riders catch this without incident. Any feed-back would be welcome.
 

·
Registered
Joined
·
151 Posts
i had the same thing happen to my bike !! dealer replaced it took a week to get the new part . put 500 miles on bike since then and havent heard a squeal yet . suzuki told my dealer the same thing they havent heard about this problem before. ya right!!
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
I new I read someone had experienced this problem. I usually just look and learn on this site ,many years of rideing and skill to learn from thanks for the responce.
 

·
Registered
Joined
·
67 Posts
Thank for the "heads up"... I just starting hearing the rear brake squeek this weekend. I'll be checking this out.
 

·
Registered
Joined
·
387 Posts
Hi, I also have the loose rotor and brake squeak. I have about an 1/8" play and have removed the pads and leveled them with an aggressive paper on a belt sander. I have about 50 miles with no squeak, but then again it has gone many miles being quiet. The pads were both concave. JOHN

I tried the brake quiet stuff and that worked for a short time.

I'll keep an eye out for the rotor getting worse.
 
1 - 5 of 5 Posts
Top