M109 Rider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
Anyone experience a rattle noise from the exhaust SET valve actuator spring when revving the engine or accelerating/decelerating?

At first, I thought it was a rattle noise as a result of a loose heat shield - but all were tight. I found the rattle to be the SET valve actuator spring by causing vibration on the pipes by tapping on the lower exhaust with my hand.

Everything seems to be OK in regards to the actuator cables, spring, etc. - not sure what to do to prevent the spring from rattling due to vibration from the engine.

But it drives me crazy ... rattles on bikes, in cars, etc. always drive me crazy.

Anyone experience this and/or have some suggestions?
 

·
Registered
Joined
·
13 Posts
I have same problem. Also like to hear if anyone had similiar problem and what they have done.

I took metal sheild off and messed with the spring, stopped rattling for a few miles and then started back up again.
 

·
Registered
Joined
·
247 Posts
yeah but i didn't know what it was.i have a set of cobra pipes and they have a heat shield.i thought that was where it was coming from.i notice it when iam taking off from first gear.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 ·
Actually, my rattle turned out to be the top exhaust pipe heat shield making contact with the bottom pipe's shield - I carefully pulled it away, putting about a 1/16" gap between the two.

I thought I had checked all the shields before - but apparently missed this.

Now ... no more metal-to-metal rattle noise!

I also had a slight rattle noise from the rear cowl (where the pillion seat goes) - I put a couple layers of duct tape around the metal hook where the cowl's plastic tab slide under - this added tension to the cowl's plastic tab and assembly when in place.

Now ... no more plastic rattle noise from the rear cowl.

The bike now is very solid with no rattle noises from vibration of motor or rough roads, etc.
 

·
Registered
Joined
·
600 Posts
One of the exhaust mounting bolts worked it's way out on mine and caused a rattle. The bolt is right under the passenger peg.

 

·
Registered
Joined
·
1,637 Posts
Trouble_Is said:
One of the exhaust mounting bolts worked it's way out on mine and caused a rattle. The bolt is right under the passenger peg.Â

Yea , mine departed too in the first week I had mine :p. Done replaced it and used locktite this time :bigthumbsup:
 

·
Registered
Joined
·
5 Posts
Mine rattles to, Took it to the dealer they said it was normal. I don't like my bike sounding like junk so i'm going to fix it.
 
1 - 7 of 7 Posts
Top