M109 Rider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Just installed a PCIII on an 07 and can't figure out what is causing the FI light to stay on. I have checked all the connections and everything is buttoned up. The diag code is C28 which is related to the Secondary Throttle Valve Actuator. I checked double checked the connection to the STVA and they are in the right places and connected.

I'm wondering if the pipes (Street Kings II) and the Fuel Processor kit/bypass cable is conflicting with the PCIII. I didn't install the pipes so I'm not sure how they affected wiring.

Anyone have any ideas? Anyone running Street Kings with PCIII?

Thanks
 

·
Registered
Joined
·
4,103 Posts
make sure nothing is in contact with the mechanical linkage from the SDTV motor to the throttle body. most of the time this happens something is in the way and will not let the motor cycle through it's range on startup and it can burn the motor out too. :bigthumbsup:
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
make sure nothing is in contact with the mechanical linkage from the SDTV motor to the throttle body. most of the time this happens something is in the way and will not let the motor cycle through it's range on startup and it can burn the motor out too. :bigthumbsup:
As in some hose or something got in the way when I put the air box back in?

I did struggle with the air box a bit.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
Steve, good call! I found one of the PCIII connectors in the way of the SDTV arm that goes to the throttle body and moved it out of the way.

No more FI light!

Thanks a lot for the help. :bigthumbsup:

Brian
 
1 - 4 of 4 Posts
Top