M109 Rider Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter · #1 · (Edited)
i purchased my 07 m109r about two weeks ago..took the bike to the nearest gas station to fill up since the fuel light was blinking and fuel level was one bar.put like 5 bucs in and it was full,turned bike on fuel light still blinking fuel gauage still shows one bar,so i thought bike is 3 years old and only has 1500 miles on it the sending unit gummed up and stuck so i put some sea foam in it and two weeks later and about 300 miles on it still doing it!!
so i maid some calls and did some research calling dealers,Suzuki,and internet and come to find out my bike had a fuel pipe recall and after a few calls found out it was fixed!!
took it to my buddies motorcycle shop when i pulled up he said please say it aint an 06 or 07, i said 07 why he said they have a lot of problems like second gear,clutch cable breaks,and rear rotor separation..he has fixed a few..
then i read the same on here..i guess im asking is there any 06 07 m109r riders who are having no problems with their bike?
 

·
Registered
Joined
·
3,367 Posts
'07 bought new. 0 problems
 

·
Registered
Joined
·
1,947 Posts
Had the rear brake rotor replaced under warranty, other than that......problem free (knock on wood).
 

·
Registered
Joined
·
1,918 Posts
Not one problem 06 silver reg motorcycle oil changed every June and end of Oct rear oil changed once a year now with synth normal blast up and down the hwy 80-90 avg but all 2 lane back roads now i don't go over 55.
 

·
Registered
Joined
·
3,873 Posts
i purchased my 07 m109r about two weeks ago..took the bike to the nearest gas station to fill up since the fuel light was blinking and fuel level was one bar.put like 5 bucs in and it was full,turned bike on fuel light still blinking fuel gauage still shows one bar,so i thought bike is 3 years old and only has 1500 miles on it the sending unit gummed up and stuck so i put some sea foam in it and two weeks later and about 300 miles on it still doing it!!
so i maid some calls and did some research calling dealers,Suzuki,and internet and come to find out my bike had a fuel pipe recall and after a few calls found out it was fixed!!
took it to my buddies motorcycle shop when i pulled up he said please say it aint an 06 or 07, i said 07 why he said they have a lot of problems like second gear,clutch cable breaks,and rear rotor separation..he has fixed a few..
then i read the same on here..i guess im asking is there any 06 07 m109r riders who are having no problems with their bike?
Brian,

Go looksee here on the forum and all will be revealed....might take a few hours/days tho :D :bigthumbsup:

BTW I have a 07 with zero probs :bigthumbsup:
 

·
Registered
Joined
·
344 Posts
have white 07 and have the drive shaft leak @ the seal towards the motor and and fuel gauge drops 3 bars all of a sudden not 1 bar at a time, under warrenty so it is all being fixed, took the extended warrenty through pro motorsports before the original expired for 4yrs. I have 10,200 mi and no problems with clutch cable yet knock on wood or clutch. I run 10-40 amsoil, k&n filters, tre and thats all the changes I have done. 113.38 rear wheel hp @ dyno basically stock love it! Fast enough. :bigthumbsup:
 

·
Registered
Joined
·
1,764 Posts
if it runs, ride it! quit worrying. it will either break or not. most dont. got a little over 4000 miles on my 07 since january. no problems here.:bigthumbsup:
 

·
Registered
Joined
·
4,743 Posts
Not to bust your balls.... but we probably don't need 2 threads for this.:bigthumbsup:
 

·
Registered
Joined
·
1,497 Posts
`07 LE w/10K miles on it and not a single problem that I didn't cause myself! 8)

my buddy has an `06 with over 30K on it with zero problems. I ride with a group of 9'ers and nobody has has a problem yet and we generally beat the snot out of them every weekend! So I'd like to know where your friend gets all his info. :dontknow:

Sure, if you read the site you will find some guys had some problems, but I would say that is the exception, not the norm.
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,855 Posts
07 with 18,000 miles and no problems so far.

The fuel rail had nothing to do with the fuel gauge. It's a metal pipe that the line from the tank runs to, then it distributes fuel to both fuel injectors. It's not in the tank.
 

·
Registered
Joined
·
165 Posts
:drool: 07 Bought new 0 problems :a18:
 

·
Registered
Joined
·
1,746 Posts
I have on 07' Pearl White. I have 7,000 miles on it. The only problem I have had is the leaky coolant hoses. A few turns of the screwdriver fixed it thus far. Thats it. Good Luck with yours. hope it's not too major.

Oh, :welcome:to the forum
 

·
Radio Active Member
Joined
·
27,666 Posts
i purchased my 07 m109r about two weeks ago..took the bike to the nearest gas station to fill up since the fuel light was blinking and fuel level was one bar.put like 5 bucs in and it was full,turned bike on fuel light still blinking fuel gauage still shows one bar,so i thought bike is 3 years old and only has 1500 miles on it the sending unit gummed up and stuck so i put some sea foam in it and two weeks later and about 300 miles on it still doing it!!
so i maid some calls and did some research calling dealers,Suzuki,and internet and come to find out my bike had a fuel pipe recall and after a few calls found out it was fixed!!
took it to my buddies motorcycle shop when i pulled up he said please say it aint an 06 or 07, i said 07 why he said they have a lot of problems like second gear,clutch cable breaks,and rear rotor separation..he has fixed a few..
then i read the same on here..i guess im asking is there any 06 07 m109r riders who are having no problems with their bike?
Once you light goes on, you have about a gallon left. Which mean you should take around 4 gallons. And if you only paid around 5 bucks for fuel, I would think that you did not put enough fuel in it. Super around here is around $3.00 a gallon, maybe your gas is that much cheaper. :dontknow: Why not pull the float assembly and take a meter to it to see if it is working properly? It is not that hard to pull out.
 
1 - 20 of 32 Posts
Top