M109 Rider Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I can't figure out what is going on with my 06 109. I have cobra swept pipes, PCIII, K&N filters and Duck covers. The bike ran fine last year. I took off the JSM as it went bad. My horse power and fuel mileage are way down. Mileage is down to 105 miles a tank. Changed fuel strainer and plugs. The bike rides fine, but does not have the pull it use too. Power is 86hp and 108ft torque. I have 13,000 miles on it. Any ideas or help would be appreciated. Thanks
 

·
Registered
Joined
·
4,105 Posts
:dontknow: The milage shouldn't have anything to do with it. I have 21,000 miles on a stock 06. It put down 108 at the wheel. The tq. would not record, but lets just say, it has a crap load of it:bigthumbsup:.
 

·
Registered
Joined
·
728 Posts
Check your throttle percentage through the power comander, should be 100% at WOT, or like V42 thinks disconnect the powercomander all together and see if you problem gets better.
 

·
Registered
Joined
·
1,458 Posts
Now if you are running really Rich you can wash out your piston rings and ruin your engine over time.

Check the connections like stated above if no problems are found sounds like you just need to re-flash the PC III.

Good Luck!
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
It was running lean before they dynoed it. It was backfiring. Now it doesnt backfire at all. How would I know if it is running rich? I know when they dynoed the bike the guy kept saying he could not get the fuel/air ration lines to get close to each other. He said the power lines were very close but fuel/air were not close at all. The bike is running fine but I can feel the power lose. It does not pull as hard as it did.
 

·
Registered
Joined
·
74 Posts
Power comander

My 109 has been sitting since I went too IRAQ. MY bike is running rich and at 27MPG. I had a cop come after me the other night and it seem to stuggel at 110mph. I've had it up to 150mph, But I don't think it will do it now.
I think it's the poer comander but I don't know how to reset it. Or if I just need a New one..
 

·
Registered
Joined
·
461 Posts
I'll take a poke at it, I've been wrong before, but did you adjust the power commander and dyno it WITH the JSM? Removing it afterward could foul things up a bit.
 

·
Registered
Joined
·
664 Posts
There is another possibility... Normally you will get some backfiring with this but not always... I would check your valve adjustment.... These engines seem to get tighter over time. I have rebuilt 3 transmissions now, and when checking the valves, one of the engines had to have 3 shims, it only had 28,000 miles on it.
 

·
Registered
Joined
·
3,308 Posts
LOL! Running from the cops is never a good time to find out you have engine problems. Here's a good slogan:

"Regular Maintenance......cause you just never know when you'll be running from the cops" :joke::joke:

My 109 has been sitting since I went too IRAQ. MY bike is running rich and at 27MPG. I had a cop come after me the other night and it seem to stuggel at 110mph. I've had it up to 150mph, But I don't think it will do it now.
I think it's the poer comander but I don't know how to reset it. Or if I just need a New one..
 

·
Registered
Joined
·
3,306 Posts
My 109 has been sitting since I went too IRAQ. MY bike is running rich and at 27MPG. I had a cop come after me the other night and it seem to stuggel at 110mph. I've had it up to 150mph, But I don't think it will do it now.
I think it's the poer comander but I don't know how to reset it. Or if I just need a New one..
If you were in Iraq, then you should be smart enough to know when the cops are chasing you and it's time to pull over. Nothing good ever comes from running.
 

·
Registered
Joined
·
709 Posts
My 109 has been sitting since I went too IRAQ. MY bike is running rich and at 27MPG. I had a cop come after me the other night and it seem to stuggel at 110mph. I've had it up to 150mph, But I don't think it will do it now.
I think it's the poer comander but I don't know how to reset it. Or if I just need a New one..
Good thing you got away to tell your story! Right......and I happen to have a bridge for sale...interested?internetracer
 

·
Registered
Joined
·
495 Posts
:agree:
Now if you are running really Rich you can wash out your piston rings and ruin your engine over time.

Check the connections like stated above if no problems are found sounds like you just need to re-flash the PC III.

Good Luck!
 
1 - 17 of 17 Posts
Top