M109 Rider Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
1)I need some of you seasoned vets, to answer (what's probably a stupid question) if the ignition switch swings about an inch either way from its pivot... is this normal?

2) Dumb question # 2: I ran my bike for about an hour, came back and let it sit for about 5 minutes and I proceeded to sit on it and check the oil, but unless I screw it in it would mark a bit low!?!

3) I'm gettin a grayish drops on my back rim, is this from overfiling?

:eek:
 

·
Registered
Joined
·
67 Posts
I can answer #2 for you. The manual makes a point of saying to NOT screw the dipstick in when dipping back in to check level. Pretty unconventional but thats the way to do it. :bigthumbsup:
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
thanks, brother!...but I must ask if you grab your ignition and lightly push left or right does wiggle at all? or is it stationary? I will drive to the dealer on Monday to ask...
 

·
Registered
Joined
·
67 Posts
OK, ran out to garage and checked. My ignition is tight. See if you can't get behind that panel where the key is and tighten that. Worth a try.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #5 ·
Thanks! :bigthumbsup:, makes me wonder what else is loose...? it sucks because I drove to Brook haven Mississippi (11,600) to get a better price, instead of buying here in Louisiana (12,540) and the local dealer acts like a jack ass when I ask for help.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #7 ·
The drops on my rim ( it happend again today ) seem to be coming from the drive shaft, no matter going back to dealer with issues, thanks guys.
 

·
Registered
Joined
·
752 Posts
Sounds like poor setup. The guys that setup and the service techs are often different.

Did you check the drain and fill plugs for your gear oil? Is there any oil around them, does it appear that the leak is there?
 
1 - 9 of 9 Posts
Top