M109 Rider Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
395 Posts
Discussion Starter · #1 ·
Hey guys and gals, have a tech question. My clear alternatives intergrated tail lights went out.. Got them to warranty it, now the lights come with there "load equalizers" a set of resistors.

I went ahead and got a set of the captain america front LED turn signals. I used the resistors from the original tail light and I get regular blinking at times, and other times I get fast blinking??:dontknow:

Should I get a better load equalizer? Am I hooking something wrong?
 

·
Registered
Joined
·
89 Posts
I would take the load equalizers and throw them as far as you can. Then go down to Autozone or your other friendly neighborhood parts house and pick up an electronic flasher for about 8 bucks and put it in. I used an FL32 and popped the signal wires out of the factory connector. This thread has all the info you need:

http://www.m109riders.com/forums/showthread.php?t=93204&highlight=equalizer
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #3 ·
Thanks bud.. Everytime I need help this site always delivers...... It is amazing to own the best bike in the world and to have an amazing web-site behind it
 

·
Registered
Joined
·
159 Posts
have to agree with both comments, the best bike and best web site. Did you crimp the wires on the load equalizers? If you did, try soldering them. Mine acted a bit goofy, I cut the crimps, did some soldering and wahla (how ever the hell you spell that) they now work great. Although the electronic flasher is a relatively cheap fix as well.
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #5 ·
Alright you guys rule again.. Finished her up today and she is good to go.... Thanks again..
 
1 - 5 of 5 Posts
Top