M109 Rider Forums banner

1 - 20 of 28 Posts

·
M109Riders Founder
Joined
·
8,014 Posts
Discussion Starter · #1 ·
Print version http://www.m109riders.com/howto/kuryturn/

I've had a couple of people that needed to know how to wire up the Kury turn signal lights so instead of trying to do it by memory or running out to the bike and taking it apart I decided to put it here instead. :doorag:

Green on the 109 goes to blue on the Kury light (Running Light)

Black and White on the 109 goes to Black on the Kury light (Ground)

Black on the 109 goes to purple on the Kury light and one of the purple's on the load equalizer (Turn Signal)

Black on the load equalizer goes to ground (I used the bolt that holds the brake manifold)

For what ever reason you have to use the load equalizer on the Kury lights or they will flash so fast that you won't be able to tell they are flashing. ::)

Hope this helps.


 

·
M109Riders Founder
Joined
·
8,014 Posts
Discussion Starter · #2 ·
MDBlvd109 said:
I'll be doing this mod this weekend...and this how to is awesome. Now I just need to figure out how to keep the chrome/plastic front light holders with the new Kury's.

Thanks Lamont
Those are steel. :bigthumbsup:

 

·
Registered
Joined
·
31 Posts
I did my silver bullets and kept the chrome bracket.Wasnt easy but was worth the time and effort.Spent some time at the hardware buying rubber washers and chromed washers.So I could fill the hole from the factory signals.Then drill out the threaded part that the chrome brakets bolt to.Mount your signals right to the chrome bracket and then mount the whole thing back to the bike one at a time.I used a nut and bolt.A pair of needles nose pliars to get the nut on the bolt helps alot.I drill the threads out because I wanted a nice size bolt and you cant get a wrench in there anyway.I put the bolt threw towards the center of the bike.I can try to take some closeups and post if need be.My email is [email protected] If anyone needs further info on it personally.I will be on a fishing trip till sunday night.So good luck all.I am still having a problem gettting the front lights to blinnk completely correct.I have single turns in the rear.Becasue huryakyn was on back order for their two curcuit ones.And the run turn brak controller was on back order.So since I was going to ralley 20 hours away.I threw it together and just ran two load equalizers.The rears are perfect,front till just dont work flawlessly.The dealership said it hard on metrics to narrow it down,since their range of signal is so wide.Harleys have less of a span,So they can meter their signal and narrow it down.The dealership said theyve installed halogen balbs behind fairings on sportbikes to the signal right.I told them that what a load equializer is for.So shows ya what dealerships know.And their working on our bikes.lol Well good luck
 

·
Registered
Joined
·
91 Posts
So these lights can be used as running lights and turn signals? If so which Kury lights are these? Model #/part #.
 

·
Registered
Joined
·
6,343 Posts
Lamont... Do you have any pics, or "How To" on how you mounted the Kury's to the stocker Chrome light bar/bracket? Looked at it this weekend and don't see how to get the Kury's mounted to the chrome piece, and get it mounted back onto the bike. It looks like the way Suzi intended it to mount was to bolt the Chrome bracket to the frame work under the headlight by going through the mounting hole for the turn signal, then insterting the signal and tightening down the screw that holds the signal in place.

To mount the Kury's it looks like you have to pull that Chrome bracket off, bolt them to it off the bike, then re-install it. Problem is with the Kury's now "In" the hole I don't see how you get the chrome bracket bolted back to the frame.

Any help is appreciated.
 

·
Registered
Joined
·
974 Posts
Ok this is probly a dumb question and all but im going to ask anyways!

Im wanting to put Kurys on front and back and debeaver my bike question is...

For the Kurys to work properly you need a load equilizer. Do you need 1 for each set of lights that you put on or can you just use one and run both off of it?

Im thinking you would need 2 of them but i wanted to make sure.

Thanks for any help.

Mike
 

·
Registered
Joined
·
600 Posts
2006moy said:
Ok this is probly a dumb question and all but im going to ask anyways!

Im wanting to put Kurys on front and back and debeaver my bike question is...

For the Kurys to work properly you need a load equilizer. Do you need 1 for each set of lights that you put on or can you just use one and run both off of it?

Im thinking you would need 2 of them but i wanted to make sure.

Thanks for any help.

Mike
I used one load equalizer for the front lights and one for the rear lights (plugged in to the Run-Turn-Brake controller).
One person posted on the thread I started about my signal mods that he found the flasher, ran one load equalizer straight off of it and that did the trick.
 

·
Registered
Joined
·
6,343 Posts
Trouble_Is said:
I used one load equalizer for the front lights and one for the rear lights (plugged in to the Run-Turn-Brake controller).
One person posted on the thread I started about my signal mods that he found the flasher, ran one load equalizer straight off of it and that did the trick.Â
Where is your thread Trouble_is... looked for it but dont see it... I am looking for ideas on the mechanical mounting for the Kury's on the front, maybe something is in your thread. (Already have de-beavered and replaced the rears).
 

·
Registered
Joined
·
600 Posts
I'm on my second version of front signals. I mounted the first pair like this:


I cut the metal stem off the stockers, drilled the center out a little and mounted the light to it. It mounted to the bike just like the stockers... slide the stem in and put the set screw back in. I was able to do it this way because the mounting bolts on those lights were pretty small, diameter-wise.


I mounted the latest set by drilling a new hole in the chrome housing. I picked up some chrome caps that cover the old stock mounting holes. I also picked up a used Run-Turn-Brake controller from a co-worker ($10) to turn these two-wire lights into running lights, too.



I'm sure someone with your particular lights will be along shortly to help out :bigthumbsup:
 

·
Registered
Joined
·
400 Posts
I have 'show chrome' signals and the only have two leads........a red and a blue......no purple/violet.....I'm working on them now...thanks for any advice.

frank
 

·
Registered
Joined
·
400 Posts
OK.......HELP !!! :eek:

lights work wired like this......

leads from LED signals are RED and BLACK

leads from Equalizer are BLACK, VIOLET AND BROWN

leads from M109 are GREEN, BLACK AND BLACK w/WHITE

here's how I have them :

Right/Left side FRONT:

BLACK on 109 to BROWN {equalizer} and to BLACK on LED signal

GREEN on 109 to VIOLET {equalizer} and to RED on LED signal

BLACK w/WHITE on 109 to BLACK {equalizer}

REAR Right

GREEN on 109 to RED on LED Light
BLACK w/WHITE on 109 to BLACK on LED Light

REAR left

BLACK on 109 to RED on LED Light
BLACK w/WHITE on 109 to BLACK on LED Light

Everything tests out O.K. even EMERGENCY Signals. That equalizer got pretty HOT.....where is the best place to mount it {the equalizer}? ....and, do I have it wired OK or is this configuration gonna 'SHAKE AND BAKE' something.......

I'm missing out on probably the "last good weather day" of the year.......but I don't want to put everything back together.......UNTIL I know this is the last step of this.....mod

Thanks for all the help.....LaMonster, the pics where a great help and I tried to see where you had your {equalizer} mounted but couldn't see it. I'll post pics of what I have when someone says........."GOOD TO GO" !!!!Â

thanks for all the help......next is the 'side mount' plate !!

Frank
 

·
Registered
Joined
·
552 Posts
Working on this atm had to come check Lamonts how to.... Ill let ya know how it turns out wether good or bad fire extinguisher or not :eek: wish me luck got it all debeavered
 

·
Registered
Joined
·
552 Posts
Got front and rear kurys on now thnx for the how to from Lamonster and JUtah for some troubleshooting both work and look great that front chrome bracket wasnt as tuff as I thought it would be. I grabbed some chrome washers from the local HD shop to fill the oem hole. Follw LTs wiring list and everything should go great for anyone doing this mod. :bigthumbsup:
 

·
Registered
Joined
·
6,343 Posts
I figured when you didn't call me back that you had it all worked out!!!

Looking forward to seeing it this weekend! :bigthumbsup:
 

·
Registered
Joined
·
246 Posts
I've looked and I've read and I am still confused. I have on '07 LE. Looking at the front of the bike my wiring is like so:

Bike wiring

Black with white stripe on both sides (ground)
Green on the left side - Black on the right side
Orange with green stripe on both sides

On the right side I have it wired as follows:

Black with white stripe from bike to black on light
Orange with green stripe on bike to blue on light
Black from bike to purple on light and purple on load equalizer

On the left side I have it wired as follows:

Black with white stripe from bike to black on light
Orange with green stripe on bike to blue on light
Green from bike to purple on light and purple on load equalizer

I have the black on the load equalizer grounded to the 3 way for the brake lines.

Now, here is the problem. When I turn on the bike my right side running light works but the but the left one does not come on at all.
When I start the bike the right side stays on and turn signal operates normally but the left side running light does not come on at all.
When I attempt the turn signal operation on the left side it blinks erratically. What's wrong and what can I do to fix it??? :dontknow: :verymad:

***UPDATE***

I changed the wiring on the left side it is now wired like this:

Black with white stripe from bike to black on light
Green from bike to blue on light
Orange with green stripe on bike to purple on light and purple on load equalizer.

The running light works fine but the turn signal is totally inoperative.
I have the same lights on the rear and they are working fine.
 

·
Registered
Joined
·
246 Posts
JUtah said:
If you are using the Kury's, wire it exactly as Lamont has called out in his first post.
I did. I just got back from the dealer for my first service and he confirmed that the wiring is correct and also that the light is bad.
Next step. RMA with DLP.
 
1 - 20 of 28 Posts
Top