M109 Rider Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
has anyone added the JSD products TRE to thier 109? is it worth it in performance?? any negatives?? nice to get rid of top gear limiter also.. did you put in the one that keeps neutral and has a switch??
thanks
 

·
Registered
Joined
·
1,409 Posts
Don't know who or what they are?? :dontknow: :dontknow: :dontknow:

Never heard of them and that usually means NO GOOD!!! :joke: :joke: :joke:


Ok... all kidding aside... BEST thing you can do for you bike IMO is put in a JSD-3M... do a little search on here and you'll find all sorts of info.
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,862 Posts
JSD used to be THE supplier of TRE's on here, then a lot of folks started having problems with them. Initially they were replacing them without much of a hassle, then they stopped being so responsive and kind of disappeared from here. The GiPro pretty much replaced them.

Jeff, the guy that owns the company, used to post on here regularly but I haven't seen him on in a while. He goes by jeffw. According to his profile it's been over a year.
 

·
Radio Active Member
Joined
·
27,668 Posts
Some people had some problems with the JSD, but I believe Jeff at JSD would take care of you. I ran it for almost two years with no issues. But have been running a Gi-Pro for the last couple of years with no issues.
 

·
Registered
Joined
·
2,071 Posts
I bought one ,it didn't work. Was sent another. It didn't work. I bought a TRE from Gman industries and it works Fantasic! Hang on!
 

·
Registered
Joined
·
3,719 Posts
My JSD always worked but I did have the issue of intermittent high idle on start up, which was always cured by shutting it down and recycling the start up. But after years of the "timing ping like" noise regardless of octane gas used....I have removed it. I didn't feel like it was doing damage but it was annoying and I felt that losing a few degrees of advance in three lower gears and about 15 mph top end in 5th was worth the peace of mind.
 

·
Registered
Joined
·
3,740 Posts
I guess I am lucky, I've had a JSD in my 9 since I bought it Jan 2009 and it's run flawlessly! I only had the high start up happen once and that was it... I am happy with mine! Smallest and Simplest mod for the bike that makes the biggest difference in low speed cruising :bigthumbsup:
 

·
Registered
Joined
·
163 Posts
G

·
My JSD always worked but I did have the issue of intermittent high idle on start up, which was always cured by shutting it down and recycling the start up. But after years of the "timing ping like" noise regardless of octane gas used....I have removed it. I didn't feel like it was doing damage but it was annoying and I felt that losing a few degrees of advance in three lower gears and about 15 mph top end in 5th was worth the peace of mind.
Then you'll like the the TDE unit. Never an issue with high idle or any of the symptoms you list.
 

·
Registered
Joined
·
1,458 Posts
I think it's really a great bang for the buck. Easy to make if you have experience building electronics on a hobby level.

http://www.m109riders.com/forums/showthread.php?t=97244

The only thing I can figure with the units not working is that the switching transistor was bad. They are subject to static discharge and if you have static electricity like dragging your feet across carpet and getting zapped you can easily blow out an electronic component. In fact you don't even have to feel a zap for it to blow out components.

I have an old transistor tester and I will shake the ones down that I am going to use for atleast 2 minutes. There is a failure rate of 1 in 8.
 

·
Registered
Joined
·
2,737 Posts
My JSD always worked but I did have the issue of intermittent high idle on start up, which was always cured by shutting it down and recycling the start up. But after years of the "timing ping like" noise regardless of octane gas used....I have removed it. I didn't feel like it was doing damage but it was annoying and I felt that losing a few degrees of advance in three lower gears and about 15 mph top end in 5th was worth the peace of mind.
I removed mine for the same reasons. I didn't like the idea that that pinging was doing something nasty in there.
 

·
Registered
Joined
·
3,719 Posts
Then you'll like the the TDE unit. Never an issue with high idle or any of the symptoms you list.
I am not saying your wrong....but if it advances the timing (or stops it from retarding) then I may still have the issue of the "ping". With all of the other performance mods I have done I no longer have a twitchy low speed throttle or low to mid range surge that was apparent from the time I bought the bike. In essence the reason I purchased the TRE is no longer a factor and I am convinced, other then 5th gear higher mph, I lost nothing from removing the unit. And at 61 years old... I don't think I need to be riding to 149mph much anymore. :D My grand kids concur :bigthumbsup:
 
G

·
I am not saying your wrong....but if it advances the timing (or stops it from retarding) then I may still have the issue of the "ping". With all of the other performance mods I have done I no longer have a twitchy low speed throttle or low to mid range surge that was apparent from the time I bought the bike. In essence the reason I purchased the TRE is no longer a factor and I am convinced, other then 5th gear higher mph, I lost nothing from removing the unit. And at 61 years old... I don't think I need to be riding to 149mph much anymore. :D My grand kids concur :bigthumbsup:
Have you upped your fuel? Running lean causes the detonation. I hear ya about not going back, just saying it may have been a defective unit. Could be a local gas thing. Could be gremlins, who knows! :)
 

·
Registered
Joined
·
3,719 Posts
Have you upped your fuel? Running lean causes the detonation. I hear ya about not going back, just saying it may have been a defective unit. Could be a local gas thing. Could be gremlins, who knows! :)
I screwed with the Fi2000r more then with my wife to nullify the "ping"....it never fully and consistently went away...screwing with my wife didn't change it much either :confused: Removing made it all better....my wife is next...:eek: J.K.
 
1 - 15 of 15 Posts
Top