M109 Rider Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,599 Posts
Discussion Starter · #1 ·
 had to drill new holes,but the local HD shop had the chrome caps to cover the original holes(only $1.49 ea....told them I'd NEVER gotten out of there so cheap!!)here's another shot....just cuz!
 

·
Registered
Joined
·
4,579 Posts
Nice job on the signals, but dude, what's up with the tassles hanging from your levers....? :yikes: :barf: Did the Harley guys at the store con you into buying those? Sorry, I know it's "to each his own" but this bike is so far from a "leather and lace" bike... IMHO of course.
 

·
Registered
Joined
·
277 Posts
Nice work on the signals!
 

·
Registered
Joined
·
297 Posts
Medic1210 said:
Nice job on the signals, but dude, what's up with the tassles hanging from your levers....? :yikes: :barf: Did the Harley guys at the store con you into buying those? Sorry, I know it's "to each his own" but this bike is so far from a "leather and lace" bike... IMHO of course.
The tassles are there to smack you in the face for putting them on this bike. To each his own. If you like it, thats all that matters.
 

·
Registered
Joined
·
3,121 Posts
I like em (fringe too) I think the fringe somehow looks cool hanging there....
NOW riding, I dont know.

Can we get the part # for the little chrome things. I will need them soon enough

Sledzep
 

·
Registered
Joined
·
1,478 Posts
tworangerted said:
 had to drill new holes,but the local HD shop had the chrome caps to cover the original holes(only $1.49 ea....told them I'd NEVER gotten out of there so cheap!!)here's another shot....just cuz!
Can you help me on how to remove the Blvd logos on the tank? Your bike looks clean!!!
 

·
Registered
Joined
·
1,599 Posts
Discussion Starter · #9 ·
sledzep...the part number is 43575.They are chrome plugs available from the parts counter at a HD store.They were like $1.49 ea.They are 5/8th inch plugs.
Baldylatino,I use a heat gun(Wifes old hair dryer!!)to remove emblems.Just spend some time heating up the emblem,then carefully pry it off.The foam tape will stay stuck,use goo-gone or I always use WD-40,just saturate it and keep rubbing.
Thanks for all the comments.....as far as the fringe,I got it last year(2005)at Sturgis as a joke for my 1600 Marauder,then really liked them...I still like them on the 109 and it sets me apart from others.Here they are on the ol 1600
 

·
Registered
Joined
·
1,478 Posts
tworangerted said:
sledzep...the part number is 43575.They are chrome plugs available from the parts counter at a HD store.They were like $1.49 ea.They are 5/8th inch plugs.
Baldylatino,I use a heat gun(Wifes old hair dryer!!)to remove emblems.Just spend some time heating up the emblem,then carefully pry it off.The foam tape will stay stuck,use goo-gone or I always use WD-40,just saturate it and keep rubbing.
Thanks for all the comments.....as far as the fringe,I got it last year(2005)at Sturgis as a joke for my 1600 Marauder,then really liked them...I still like them on the 109 and it sets me apart from others.Here they are on the ol 1600
Thanks for the tip, I finally Got them off and it looks great, thanks for your help, I need to find out how to post pics now!
 

·
Registered
Joined
·
1,466 Posts
Medic1210 said:
Nice job on the signals, but dude, what's up with the tassles hanging from your levers....? :yikes: :barf: Did the Harley guys at the store con you into buying those? Sorry, I know it's "to each his own" but this bike is so far from a "leather and lace" bike... IMHO of course.
Me likey the lights

Me no likey the tassles.
 

·
Registered
Joined
·
443 Posts
Tassles? Say it a few times. Just doesn't sound right. :dontknow: :joke: Ahh, just kidd'n. To each, his own. :p
 
1 - 16 of 16 Posts
Top