M109 Rider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
And i heard a clunk sound in the clutch gear box.And i adjusted the cable wire to capacity and my clutches are not fully engaging.And when they do it jerks off before i can let the clutch go.Please help me someone^-^
 

·
Registered
Joined
·
137 Posts
check the cable where it enters the clutch lever perch, is it frayed? If not it may be the clutch tube nut backed off....
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Thanks

check the cable where it enters the clutch lever perch, is it frayed? If not it may be the clutch tube nut backed off....
Thank you its not frayed.I think its the clutch bolt i will check.If so how much is the bolt and can the bolt be put back on
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
Hmmmmm, so when you say they're not fully engaging, the clutch slips? From what I read on your post it seems like you can't disengage your clutch :dontknow:. The clunk sound and "And when they do it jerks off before i can let the clutch go" sounds like tube nut symptoms.
the clutch will engage but with a little power.And then sometimes it takes off like a rocket without even letting off the clutch.It does what it wants to do.The bike is a 2008 with 2600 miles on it.So i doubt that my clutches and springs are fried.
 

·
Registered
Joined
·
203 Posts
Tubular Nut

Hello:

Take a look at the posts on the Tubular Nut. :tools:

Ride Safe!!!
 
1 - 6 of 6 Posts
Top