M109 Rider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,846 Posts
Discussion Starter · #1 ·
Yes the dreaded old water leak which has been misdiagnosed by more than 1 dealer in the past occurred to me today.

Just tighten up the hose clamp which attaches the hose between the cylinder heads. Honestly, no sweat!

I have roughly 1200-1300 miles on my 109 and it occurred to me.

Because of this site, I knew that it was very commom & easy to fix, no trip to the dealer! :p :bigthumbsup: :doorag:
 

·
Registered
Joined
·
1,035 Posts
Sweet! Thats whats so kewl about this site, you don't have to go looking to your dealer for things you can do yourself and save the 150.00 service fee on.. Especially since this is a factory issue and not a rider issue.
 
G

·
ppridgen1 said:
glad we came in handy and feel free to post any other problems ,because the more we all communicate the better off we all are going to be :bigthumbsup: :doorag:ps and remember the only stupid question is the one you didn't ask!!!!!!
Exactly... :bigthumbsup:Â The hose that was leaking on mine,,I had to remove the airbox,,,,and set aside....took alittle bit ....but its fixed for sure now....I contacted suzuki and sent them this pic and told them My stealer prob sent them a warranty claim ,,on this and let them know,,they didnt fix it I DIDI!!!!.....Hope zuki denies their claim...
 

·
Registered
Joined
·
750 Posts
I had the same problem. Did not want to take it to the Dealer because I wanted my bike to ride, not sit with the mechanics for a couple of days while the tried to figure it out. All in all it took about 2 hours to remove everything and put it all together. :bigthumbsup:
 
1 - 4 of 4 Posts
Top