M109 Rider Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
:D

Just found out about this board tonight. It has been an interesting read so far. One problem I have had with this m/c. Suzuki installed hose clamps on the coolant hose running from the waterpump past the rear jug and on up to the heads. These clamps are not the correct size and they bottom out (no threads left in the clamp) . The leak started after the wife put about 100 miles it. ordered new clamps for the local auto store and installed. AOK now. Just thought I'd let you know

Warren G
Ft Sask Alberta

98 valk
02 vtx 18
03 Blackbird
M109R
 

·
Registered
Joined
·
1,552 Posts
welcome to the board. already posting tips, i like that :p
 

·
Registered
Joined
·
169 Posts
Hmmmm....Now I have to go crawl around on the garage floor tonight.

Thanks for the heads up and Welcome!
 

·
Registered
Joined
·
1,046 Posts
longrider said:
:D

Just found out about this board tonight. It has been an interesting read so far. One problem I have had with this m/c. Suzuki installed hose clamps on the coolant hose running from the waterpump past the rear jug and on up to the heads. These clamps are not the correct size and they bottom out (no threads left in the clamp) . The leak started after the wife put about 100 miles it. ordered new clamps for the local auto store and installed. AOK now.

98 valk
02 vtx 18
03 Blackbird
M109R
The wife put 100 miles on it?! Could this be our first female 109er? If so welcome aboard! and if not, Welcome aboard! This is a great place to get tips!
 
1 - 6 of 6 Posts
Top