M109 Rider Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5,562 Posts
Discussion Starter · #1 ·


This one by cycle house Part #: CYC-M109406

I ordered mine in Jan 2010 and didnt put it on till after the snow melted so its been on the bike since April (there is even a thread on the install) ...

But my question is ANY OF YOU GUYS/GALS THAT BOUGHT THIS KICKSTAND are you having any issues with the chrome..?? Mine is pealing from the backside of kickstand.. and wondering if its just mine or is this common... THANKS Ride Safe! :bigthumbsup:


and yes it is scratched on the bottom....

best picture I could take of the pealing chrome... from the bottom up..



:dontknow:
 

·
Registered
Joined
·
1,478 Posts
Can you post a pic of ur bike with the new kickstand? Ive been wanting to buy one but not sure how my bike would look, thanks!
 

·
Registered
Joined
·
5,562 Posts
Discussion Starter · #7 ·
Here's what mine is doing.
thats exactly what mine is doing...!! How long have you had your on?? 4 months or so for mine.... thats crap! Yes I did contact DLP with no reply so I emailed Hal... few replies but no solution as of yet...
 

·
Registered
Joined
·
1,219 Posts
Mine started pitting on the top side of the base. I clean and polish it all the time but its like the metal underneath is corroding. I will post a pick of it as soon as I get a chance. :eek:
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,860 Posts
I've had the holed one on for about two years and no pealiing. It is scratched quite a bit on the bottom, as you would expect to to be from parking on pavement and concrete. It also has some fine scratches on the top from raising and lowering it with my boots.

I'm actually amazed the chrome stays on these, especially near the bottom, with the abuse they get.
 

·
Registered
Joined
·
163 Posts
It was on the bike when I bought it. It was like that then too. So not sure. If all the stands are doing that in the same place sounds like manufactures defect in the plating or metal base it self.
 

·
Registered
Joined
·
5,562 Posts
Discussion Starter · #11 ·
yea and like ZOOM said the one with the holes in it arent having a problem..... I know a few guys that have the one with the holes in it and have had NO problems.... HUMMMM Wonder if Hal will replace it... $179 bucks you would think it would last longer than 4 or 5 months.... :dontknow:.:pop:
 

·
Registered
Joined
·
1,599 Posts
my holed one has had the chrome peeling for about a year......
 

·
Registered
Joined
·
582 Posts
NOT TRUE

Hey I have the one with the holes standard size and the chrome is coming off at the same location , they said they would replace it at dlp but I never got around to removing it ,, oh well my loss.. ride safe
 

·
Registered
Joined
·
5,562 Posts
Discussion Starter · #14 ·
Hey I have the one with the holes standard size and the chrome is coming off at the same location , they said they would replace it at dlp but I never got around to removing it ,, oh well my loss.. ride safe
wonder why they are blowing me off then.... :dontknow:
 

·
Registered
Joined
·
6,984 Posts
thats exactly what mine is doing...!! How long have you had your on?? 4 months or so for mine.... thats crap! Yes I did contact DLP with no reply so I emailed Hal... few replies but no solution as of yet...
Sounds like a plating problem to me with so many of y'all having the same problem.

I've had the holed one on for about two years and no pealiing. It is scratched quite a bit on the bottom, as you would expect to to be from parking on pavement and concrete. It also has some fine scratches on the top from raising and lowering it with my boots.

I'm actually amazed the chrome stays on these, especially near the bottom, with the abuse they get.
That's just what mine looks like too, Zoom. I am actually surprised how good mine still looks. I wonder if a different chromer was used on our "hole stands" :dontknow:.
 
1 - 15 of 15 Posts
Top