M109 Rider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
Just picked up my bike from the stealer after its 600 mile (802 for me) service. Was hesitant to let them do it, but it was "free." The bad part was i had to leave it overnight and couldnt stick around to supervise.
So far it is all good.
*Oil level is perfect.
*Seems to have smoother/ quicker throttle response
*There are several grease marker dots on the various chassis bolts and rear axle fills so ill assume they have been torqued.
*Clutch has been adjusted, much quicker but still has the intermittent 2nd gear "personality."

All in all i am happy, but there is no substitute for doin it yourself. Not to mention you can leave on the jsd mod without fear of dealer spanking.

ride on :doorag:
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #5 ·
toneout said:
Maybe they adjusted any slack out of the cable.
That is my guess too.
I dont know if the throttle bodies were out of synch though and if so if that made a difference.
 

·
Registered
Joined
·
4,103 Posts
there is no call at the 600 mile service for the dealer to hook up diagnostics to the bike or synch the throttle bodies. they may well have adjusted the slack in your throttle cables as thats about all they do at 600 mile service is oil/filter, rear end oil, tighten adjust loose stuff. the Euro/Aussie bikes have the synch done I assume since they have the o2 sensors they have to be a little more precise.
 
1 - 6 of 6 Posts
Top