M109 Rider Forums banner
1 - 13 of 13 Posts
G

·
Discussion Starter · #1 ·
At the end of the riding season here in wisconsin...I finally run into my first major problem with my black beast!! Found some dried up spots of anti-freeze on the right side of the engine!! So...I'm thinking no big deal....those hose clamps must have loosened up like on so many other 109's out there. But....I have 5250 miles on my bike and as I recall...most of the leaks from the loose clamps started happening with-in the first 500 miles give or take. I inspected the motor a little longer and found the whole upper half of the front head had oil dripping down it!! :yikes: Now I start to freak out!!! Brought it in today to get looked at....I'll let you all know what 's up with it as I find out.
 

·
Registered
Joined
·
1,768 Posts
I believe the coolent leak can occur anytime. I had 9000 trouble free miles when I developed a leak on the rear cylinder hose. It occurred only once after reeving the bike to red line. Tightened the hose clamp and haven't had a problem since. Hopefully your oil leak needs nothing more than a snugging of the top end bolts.
 

·
Registered
Joined
·
665 Posts
Let your dealer look at it. It's covered under the warrentee!
 

·
Registered
Joined
·
292 Posts
well it couldn't of happend at a better time of the year for you.....being up there in Wisconsin its probably snowing or at least to nasty to ride ...this spring you should have a almost new bike......did it seem a little under powered or blow white smoke or anything....maybe a bad head gasket...
good luck....keep us posted
 

·
Registered
Joined
·
315 Posts
Keep us posted... Hopefully it is something simple.
 
G

·
Discussion Starter · #12 ·
Well...talked to the dealer today. Seems like nothing major!! All he could tell me so far is that they are relacing 3 gaskets....but not major gaskets....he said they where smaller ones. Maybe where the oil and anti-freeze intake into the motor?? Sucks.....it's supposed to be in the 60's up here in wisconsin this next week....and no bike!! :(
 
1 - 13 of 13 Posts
Top