M109 Rider Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
961 Posts
Discussion Starter · #1 ·
Just got a call from the dealer that my shaft cover came in. I ordered it in May and it's now Sept. Suzuki could have done a better job in their R&D dept. on accessories for the M109 and it's availability. Well I guess I'll put it on this evening, I went on a 400 mile ride this weekend and my back is killing me, it's the first time that this has happened. My next upgrade is a gel seat or have the original one repadded.

C-One
 

·
Registered
Joined
·
961 Posts
Discussion Starter · #5 ·
Bruno,

I looked at your pics and initially my cover was installed looked like yours. I noticed the instructions weren't that good to begin with. Instead of snapping the rear of the cover over the drive shaft bolts, I slip the cover forward over the shaft and then pushed it backwards over the bolts and additional 1/4 ". I have no spaces showing between the cover and the bolts are all hidden. I also installed the clamp differently, I postioned the clamp that when I tighten it, it's positioned under the shaft and angled to the inside opposed to the side that the instructions directed you to install it, the clamp was rather close to the tire doing their way. Although there was enough clearance between the tire and clamp, I did it my way and the clamp isn't visible. I'll post some pics this evening.

C-One
 

·
Registered
Joined
·
961 Posts
Discussion Starter · #6 ·
JR,

What happened to the option to insert files in your post? Has it changed?

Let me know where I can send them.

C-One
 

·
Registered
Joined
·
961 Posts
Discussion Starter · #7 ·
I just sent them. Dial-up is a joke once you've had high speed access.

C-One
 
1 - 9 of 9 Posts
Top