M109 Rider Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter · #1 ·
Hey guys got home and noticed the FI light on....bike running good but saw the light and WTF???? Mods are cobra swepts and PC III... can anyone tell me whats going on or any ideas????

DA BOSS
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #3 ·
FI light

C-mon guys..i did the search and didn't find the answer...when i turn the kill switch on the light goes off...but when i turn the kill switch off the FI shows up and stays on...doesn't blink... trying to figure something out here..help me out!!!!!!!!! do i need to get the paperclip to get the codes????
 

·
Banned
Joined
·
15,179 Posts
I don't know but

Here is the manual to work on this beast , section 5 FI system diagnostic section, Explains everything about FI there, sorry I couldn't do more.

http://www.mediafire.com/?m2zniyn4ltj
C-mon guys..i did the search and didn't find the answer...when i turn the kill switch on the light goes off...but when i turn the kill switch off the FI shows up and stays on...doesn't blink... trying to figure something out here..help me out!!!!!!!!! do i need to get the paperclip to get the codes????
 

·
Radio Active Member
Joined
·
27,670 Posts
You first need to find out what code it is sensing and then take it from there. There is a how to on it.
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #7 ·
special tool

can i use a paperclip to pull the codes??? or use the wire??
 

·
Banned
Joined
·
15,179 Posts
CODE MALFUNCTION PART REMARKS
C00
C12
C13
C14
C15
C17
C21
C23
C24
C25
C26
C27
C28
C29
C31
C32
C33
C40
C41
C42
C44
C46
C49
C60
C61
C64
None
Crankshaft position sensor (CKPS)
Intake air pressure sensor #2 (IAPS #2)
Throttle position sensor (TPS)
Engine coolant temp. sensor (ECTS)
Intake air pressure sensor #1 (IAPS #1)
Intake air temp. sensor (IATS)
Tip-over sensor (TOS)
Ignition signal #1 (IG coil #1.1)
Ignition signal #2 (IG coil #2.1)
Ignition signal #1 (IG coil #1.2)
Ignition signal #2 (IG coil #2.2)
Secondary throttle valve actuator (STVA)
Secondary throttle position sensor (STPS)
Gear position signal (GP switch)
Injector signal #1 (FI #1)
Injector signal #2 (FI #2)
Idle speed control valve (ISC valve)
Fuel pump control system (FP control system)
Ignition switch signal (IG switch signal)
Heated oxygen sensor #2 (HO2S #2)
Exhaust control valve actuator (EXCVA)
PAIR control solenoid valve #2 (PAIR valve #2)
Cooling fan control system
PAIR control solenoid valve #1 (PAIR #1)
Heated oxygen sensor #1 (HO2S #1)
No defective part
Pick-up coil signal, Generator
For Front cylinder
*1
For Rear cylinder
For Rear cylinder
For Front cylinder
For Rear cylinder
For Front cylinder
*2
For Rear cylinder
For Front cylinder
Fuel pump, fuel pump relay
Anti-theft
For E-02, 19, 24
Except for E-03, 28, 33
Cooling fan relay
For E-02, 19, 24

That didnt work to well, but I think you can just go first code first wording below and so on
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,877 Posts
can i use a paperclip to pull the codes??? or use the wire??
You can use a paper clip, just make sure you don't short it to metal somewhere. I use a short piece of wire with just the ends stripped off so I don't have to worry about it.
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #10 ·
code

Got the code C00...which means no malfunction....that's the good part!!! now how do i clear the FI from the screen?????
 

·
Registered
Joined
·
16,261 Posts
Hey guys got home and noticed the FI light on....bike running good but saw the light and WTF???? Mods are cobra swepts and PC III... can anyone tell me whats going on or any ideas????

DA BOSS
Is it on while you're riding? And did it happen after changing the exhaust?
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #14 ·
Problem solved

:a18::a18::a18:problem solved...got rid of the FI light....pulled the black with brown stripe wire and POOF!!!!!!!!!! no more FI light....thanks so much guys for your help!!!!!!!!!!

DA BOSS
 

·
Registered
Joined
·
1,607 Posts
:a18::a18::a18:problem solved...got rid of the FI light....pulled the black with brown stripe wire and POOF!!!!!!!!!! no more FI light....thanks so much guys for your help!!!!!!!!!!

DA BOSS
:a18:You're welcome, Zoom showed me that one.:bigthumbsup:
 

·
Registered
Joined
·
14 Posts
I checked the code on mine and it showed C00. Since the manual says the code can only be cleared using the SDS software (and it wouldn't clear by disconnecting the battery), I took it to a local Suzuki dealer. When they checked it, it indicated C46. They then showed me how the exhaust servo would rotate one direction when the key was turned on, but wouldn't return to the starting position. Apparently the plastic gears in the servo unit had stripped (a common problem on Suzuki sport bikes). Since I still have the stock exhaust (with Scorpion tips), I opted to get it fixed. Because this is part of the emissions system, the manufacturer apparently has to fix it for 5 years. No cost to me! :D
 

·
Registered
Joined
·
213 Posts
I checked the code on mine and it showed C00. Since the manual says the code can only be cleared using the SDS software (and it wouldn't clear by disconnecting the battery), I took it to a local Suzuki dealer. When they checked it, it indicated C46. They then showed me how the exhaust servo would rotate one direction when the key was turned on, but wouldn't return to the starting position. Apparently the plastic gears in the servo unit had stripped (a common problem on Suzuki sport bikes). Since I still have the stock exhaust (with Scorpion tips), I opted to get it fixed. Because this is part of the emissions system, the manufacturer apparently has to fix it for 5 years. No cost to me! :D
I really hate to go all necromancer on a thread, but how did they pull the c46 code? every time I try pulling the code for my fi light all I get is the c00. I am using a paper clip. should I use an actual piece of electrical wire?
 

·
Registered
Joined
·
213 Posts
yes. that's how I found out which connector and terminals to jumper to get the codes. but like I said, I used a paper clip and was wondering if I should have used actual wire since the only code that is showing up is c00. I even tried pulling the code with the engine running and all I got was c00. I was asking cause AZ_9 said he went to a dealer after reading a c00 and they pulled a c46. long story short, I'm just trying to avoid doing the pin 7 "mod". with all of the electronics on these modern bikes, I like knowing when something is wrong. one thing I am seriously considering doing is building in a fi light switch, so when it comes on while it's running or I'm riding, I can flip it to see what's going on.
 
1 - 20 of 32 Posts
Top