M109 Rider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
So from the reading I have done on the old posts I have found that if you have a non-stock exhast installed (mine is V&H big shots). And you have a solid F1 light on all the time the best thing to do is to remove the SET actuator all together. For this I will have to pull the pin from the ECU.

Is the above correct?

Thanks in advance.
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
23,090 Posts
That would be correct. Remove the actuator completely, then pull the pin on the ECU. The light should go out, providing it's caused by a failed SET actuator.
 

·
Radio Active Member
Joined
·
27,696 Posts
You are correct and I would also wrap up the two connectors and the pulled pin up and to keep them clean and dry. So if you want to ever switch back, you can do so trouble free.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #4 ·
Woot the light is out! Thanks for the confermation and to the original poster of the fix. Bet that 15 mins of my time would have cost me $300.00 at a dealer.

Now I just need to figure the pc3 unit out and I can start burnin more miles before we get snow.

Love this site.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #6 ·
Sweet, didn't take you long either. :bigthumbsup::bigthumbsup:
Helps that I used to be an automotive mechanic and still have a huge box of tools and a little knowlege. But lets face it if you can learn from others why waste all night reading the manual. Leaves more time for rideing.
 
1 - 6 of 6 Posts
Top