M109 Rider Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all. First off I am new and I’m sure I’m posting this in the wrong place or the problem has it’s on …… Sorry I don’t know what it would be called. Like in the title I have an F1 error code. I have a 2013 with 39k. The light first came on last year during my annual long trip. About 4k miles and camping off the bikes the whole way. I have read a lot of posts about the F1 code but they seem to be related to modifications made to the bike. For me my bike is basically stock. Aside from full front faring and hard bags this bike is stock. Any ideas what would be causing the code? Also the light comes on after about 30 minutes of riding and stays. If I park the bike for a long enough time the code will not display when I start the bike but it will come back after about 30 minutes. If anyone has an idea of what it could be or knows where I can locate the information I need I would be very grateful. Thank you all in advance.

With Respect,
Young, G.W.
 

·
Registered
2009 / VZR1800
Joined
·
3,992 Posts
Hi all. First off I am new and I’m sure I’m posting this in the wrong place or the problem has it’s on …… Sorry I don’t know what it would be called. Like in the title I have an F1 error code. I have a 2013 with 39k. The light first came on last year during my annual long trip. About 4k miles and camping off the bikes the whole way. I have read a lot of posts about the F1 code but they seem to be related to modifications made to the bike. For me my bike is basically stock. Aside from full front faring and hard bags this bike is stock. Any ideas what would be causing the code? Also the light comes on after about 30 minutes of riding and stays. If I park the bike for a long enough time the code will not display when I start the bike but it will come back after about 30 minutes. If anyone has an idea of what it could be or knows where I can locate the information I need I would be very grateful. Thank you all in advance.

With Respect,
Young, G.W.
First, welcome to the forum! Cheers... 🍻
FI error code needs to be read first, to determine what is it trying to tell you.
When you come home with it lit up, do not turn the bike off with the key, use only
kill switch, an access the white test plug covered with black rubber boot.
It is located on the left side of your bike under the left plastic cover. See it here:
Plug in the piece of wire described there and your code should pop out.
Meaning of the codes are here:
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
23,609 Posts
Welcome to the forum. :)
thevili provided all you need. The key thing to remember is the light has to be on and do not turn the bike off. Once you do the code is gone. Either leave it running until you pull the code or use the kill switch to stop it and leave the key on.
 

·
Registered
2015 Suzuki Inturder (M109)
Joined
·
2 Posts
Thanks for the tip. I am also new to the forum. I get the F1 light at times when just turning the key on. It usually goes off after turn the key off and back on again. I will try to pull the code next time!
 

·
Registered
Joined
·
3,864 Posts
Thanks for the tip. I am also new to the forum. I get the F1 light at times when just turning the key on. It usually goes off after turn the key off and back on again. I will try to pull the code next time!
The FI light does come on for a moment when you turn the key on.
As long as it goes out when you start the bike, then you are fine.

BCS
LGB/FJB
 

·
Registered
Joined
·
3 Posts
The FI light does come on for a moment when you turn the key on.
As long as it goes out when you start the bike, then you are fine.

BCS
LGB/FJB
Yeah, that’s the problem. It doesn’t go out once started. I just picked up this bike and don’t know too much about it. I know a power commander was installed along with aftermarket pipes. Not sure if mods to wiring was done or not. Will need to read the code to see where this leads.
 
1 - 7 of 7 Posts
Top