M109 Rider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Today my 109 left me stranded 29km from home.I have been having trouble with the bike after riding for 1hr or so bike would start sputtering and not rev past 3500rpm,well today bike started to sputter to the point where it wouldn't pull itself.I had taken off the jsd mod thinking it was that but it wasn't.I think its a coil or ignition problem.I talked to dealer and he says he is full till July 23.I will be taking the bike in tomorrow and I want it worked on unfortunately I paid cash for the bike so nobody really seems to care if it runs or not.Good luck my brothers I hope you all are trouble free on your bikes and ride safe.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #3 ·
Ya I tried everything I could think of.Removed and flushed tank thinking it might be bad fuel.Removed jsd.Checked all vacuum hoses.Checked plug wires from coil.Disconnected battery to reset computer.Removed air cleaners checked for oil.That is all my ability allows me so hopefully I can encourage dealer to make it a priority.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #4 ·
Have never had f1 light come on, and up until 3300km the bike has been exceptional and very strong.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #5 ·
Took the bike to dealer he says I am RIDING THE BIKE TO FAST.So I guess you all out there are a bunch of girls.I thouhgt I bought the king of cruisers not the CLOWN of cruisers.I loved and talked this bike up to anyone that would listen now I am so pissed I want to sell IT.This is a joke, If myself a 45 years old father of 2 married 20 years is driving this bike to hard then Suzuki have built a F---ing lemon.
 
G

·
You need to quit trolling and go buy a Burgman. Also, quit duplicating your own threads looking for sympathy. Buy bye.
 
1 - 8 of 8 Posts
Top