M109 Rider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
Hi

Don't know if I was the only one with this issue!

My coolant was leaking from both sides it seems down to the engine and finally onto the Clutch cover plates and down specially when I parked it! :mad: :evil:

At my 800 Mile service point I was told it's the reservoir tank that was loose and they had changed the clip and then the problem only got worst, to the point that it was almost leaking daily! And being crazed about keeping it SPOTLESS it was just too much cleaning!:eek:

Finally they took it again and found it the coolant was leaking from inside, and in between the big Chrome Covers, apparently the line running there leaked all the time just happen to show more every time I parked the bike and leaned it!

It was fixed and after a complete cleaning it leaked the next day, I figured damn it's back again but I just cleaned it up and ran it and so far I am at about 1200 Miles and it seem to be fine! :bigthumbsup:


ANYONE ELSE had the same issue???? :cop:
 
G

·
yep,,just had mine at the stealers for this.....they of course,didnt bother to even clean up the old coolant trails ...so,,is mine fixed,,we'll see. ... :eek:
 
G

·
Speaking of which,,anyone know where the coolant overflow bottle is hiding?...I'd like to check and see it they topped it off...not gonna hold my breath... :verymad:
 

·
Registered
Joined
·
168 Posts
traysvega said:
Speaking of which,,anyone know where the coolant overflow bottle is hiding?...I'd like to check and see it they topped it off...not gonna hold my breath... :verymad:
Tray you don't have to take the tank and covers off too check the level ............just to top it up.( a light helps)
Dave
 
1 - 7 of 7 Posts
Top