M109 Rider Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
552 Posts
Discussion Starter · #1 ·
Well I finally experienced the coolant leak and I shuffled through the forums and found some good stuff here about this problem....so I thought anyhow. I pulled the sides off and tightened the clamps then cleaned her back up after a very short ride to work the next morning I noticed it was still leaking. :eek: So I call the dealer I purchased it from and tell them Im bringing it in after work, once again in the short ride from work to the dealer maybe 5 miles I smell the coolent really well now and look down it is spraying down the left side at a very steady space when I pull into the dealer. They check it out and notify me that the thermostat is cracked and it will be a warranty issue. Just wanted to post in case anyone else experiences this type of leak and for those that have had coolant leaks may wanna take a peak at the thermo. Thnx
 

·
Registered
Joined
·
721 Posts
I am leaking from somewhere towards the front... Spraying on the top of the left air intake and see it near the fan and such... Some drops on the clutch cable.

I would assume the thermostat is in there somewhere?

Anyone else get a leak up front?
 

·
Registered
Joined
·
721 Posts
From another thread.....

"Pulled the radiator shroud off and I was able to see it appeared to be coming from the top of the front cylinder head (oh crap!). Pulled the tank back and found that in fact it was coming from a coolant hose where it Ts (T appears to be made of plastic) off behind the radiator. I reached in with my finger to see if I could turn the clamp so that I could get a better angle on it to tighten it and guess what! It was loose!!! I could push it around with little effort and upon checking the other two hose clamps in that area they were loose too though not as loose as the other."

Guess I am pulling my shroud after work :edit: :verymad: ::)
 

·
Registered
Joined
·
197 Posts
Had an issue on the very cold mornings the left side got soaked in coolant twice,on top of starter and fan and on top of left air filter and left side of bike. The dealer said my radiator was leaking and changed it out for me under extended warrantee.
 

·
Registered
Joined
·
721 Posts
Lower hose on the "T" took 1/2 or 3/4 turn to snug it up good and looked like it may have been leakin from that point.
Tightend the other 2 about 1/4 turn each.

Topped the coolant off and let it run long enough for the fan to cycle on/off twice... No leak seen.
Will watch it for a few days and see what happens.

Will try to post pics tomorrow evening.

Thanks to TrickyRick55 for letting us know about this one...
 

·
Registered
Joined
·
305 Posts
I noticed a similiar leak. I will be taking my bike in for inspection this week.
 

·
Registered
Joined
·
306 Posts
:agree: Very useful...thanks! :bigthumbsup:
 
1 - 9 of 9 Posts
Top