M109 Rider Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
just got on bike today rode for half our then it started smoking ,rode home quickly no warning lights good, noticed the level was very low, tried to fill when cooled down ,and it was coming out bottom as fast as i was putting it in , next step is to take off plastic and see whats up, what do you think i should expect to find, looked up radiator replacement on line around $400 wow any aftermarket fit, today is thursday i will jump on this tomorrow thanks for any help.
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
23,090 Posts
It was coming out the bottom while you were pouring it in the reservoir? That sounds like the reservoir may have cracked. Let's hope so as that would be a lot cheaper to fix. You can pick one of those up off ebay, as well as the radiator if you happen to need one. A member on here, Rainey5230, also sells a heavy duty replacement radiator. He sells them on ebay too.

It could also be a loose radiator hose clamp, there's several that can leak, but since it's running out while you're adding it that doesn't sound like a loose hose. The radiator will draw fluid from the reservoir as it cools down, but it doesn't draw it in that fast.
 

·
Registered
Joined
·
1,746 Posts
:agree:With Zoom. I would not think it is hose. I had a little leak, that I only saw after running hard. I tightened up my hoses. So far so good.

Unless your radiator has a huge hole in it, I would think it might be the reservoir.
Good luck with it. Let us know what it was.
 

·
Registered
Joined
·
3,719 Posts
If it turns out to be a reservoir place an add in WTB in the forums...several members here have had totals and had reservoirs for sale.
 
1 - 5 of 5 Posts
Top