M109 Rider Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 ·
I wanted to know from the fellas (and ladies) who have the Fi2000 aftermarket pipes and high flow air filters, what they have their FI2000 pots set at. Thanks in advance.
 

·
Registered
Joined
·
443 Posts
J R said:
try 2,4,3
What would you think the settings should be at 4600 feet above sea level? :dontknow:
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #3 ·
2, 4, 3. Jr, do you have your main jet pot set to three? I had mine high like that but I thought it was kinda rich. The 2, 4,3 is green, yellow, red right? Thanks for the input, just trying to get this thing dialed in. Be safe.
 

·
Registered
Joined
·
443 Posts
I agree JR, fat is better than lean! :bigthumbsup:
 

·
Registered
Joined
·
443 Posts
J R said:
As long as we are talking about air fuel ratios and not women :p :joke: :joke: :joke:
AGREED! :joke: :bigthumbsup:
 
G

·
Currently using 0,0,0. Bike has cobra slashdowns, FI2000r, JSD-3M Auto, and some shiny bits.

Popped like all hell when I used std settings. Got worse when I used 2,4,3 or 4,2,3, or whatever.
I think it STILL has too much fuel.
Must be because its an Aussie model that has o2 sensors STD.
Need to dyno next week to get it sussed.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #7 ·
Thanks to all you guys for the input, I will just have ti fiddle with it. Also remember....fat girls need :eek: love too.
 
G

·
0,0,0. Tried std. popped on decel. Tried JR's 2,4,3. Popped even worse. Also, black-smoked on throttle blip, sure sign its rich, so slowly backed off every dial until all zeros. Could even take out more if fi200r let me.
Will chk plugs 2morrow and see whats what.
 

·
Registered
Joined
·
514 Posts
I hate to ask this question...

but are you doing this tuning on a dyno with a/f probe? If not I can see why people are reporting troubles (knocking, popping, smoke, etc). You are shooting in the dark w/o a probe and the bike under load.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #11 ·
That's a good point but i don't have a dyno in my garage so that might have to wait. By the way, I have one of your devices on my bike and when I pull the clutch in the rpm's goes up. I thought this was supposed to preserve neutral. Lemme know.
 

·
Registered
Joined
·
532 Posts
I only have the JSD-3M and the Edelbrock filters and I just adjusted mine on Sunday by riding it and adjusting it. I came up with 2,4,2. Later, I was looking at some of JR's posts and saw that he recommended about the same (2,4,3). He is in about the same climate as I am with a little more humidity. I'm going to try the last setting on 3 today and see how it works out.
 

·
Registered
Joined
·
514 Posts
pizzmor said:
That's a good point but i don't have a dyno in my garage so that might have to wait. By the way, I have one of your devices on my bike and when I pull the clutch in the rpm's goes up. I thought this was supposed to preserve neutral. Lemme know.
Does it have a ground wire?
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #14 ·
Jeff,

Yeah it does and I think I have it grounded properly. If it is not properly grounded would that cause what I described?
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #15 ·
I am tired of F-ing around with this Cobra unit, so I orderd the power commander tonight. Anyone want to buy a Fi2000?
 

·
Registered
Joined
·
1,846 Posts
eire1965 said:
I only have the JSD-3M and the Edelbrock filters and I just adjusted mine on Sunday by riding it and adjusting it. I came up with 2,4,2. Later, I was looking at some of JR's posts and saw that he recommended about the same (2,4,3). He is in about the same climate as I am with a little more humidity. I'm going to try the last setting on 3 today and see how it works out.
My FI2000 worked like a champ, especially low to mid range with the settings 2,4,3. I had the JSD-3M & 3 baffles drilled out of each exhaust at the time.

Chuck
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #17 ·
Yeah I don't want to give the wrong impression here. The Cobra works awesome, but I want the option of adding and making custome maps for the 109. It is more out of the urge to tinker than anything else.
 
G

·
jeffw said:
I hate to ask this question...

but are you doing this tuning on a dyno with a/f probe? If not I can see why people are reporting troubles (knocking, popping, smoke, etc). You are shooting in the dark w/o a probe and the bike under load.
Hey Jeff,
Firstly, great product the JSD-3M Auto. And yep, you were right in your emails. Instructions in the packet you sent were for the wrong model, but the JSD worked great when I plugged it in. Australias a long way away when a delivery goes pearshaped, so thanks for your prompt attention mate :bigthumbsup: :bigthumbsup:

So far, no dyno, and no probe. One guys is booked until the end of Oct, the others dyno is dead, so I'm using the old fasioned tuning tools I used as a kid; eys for black smoking exhausts and plug colours, ears for popping on decel or rattling for detonation or pingijng metal for a too-hot running engine, and the bum dyno for smoothness and speed. Its not exact, but I remember it worked a treat on my old charger......just hope I'm not too far off with the 109. Dont wont to hole a pistion.
I think the vast differnance on fi2000r setting between US and here in Aussie is to do with the open loop fuel map the bike defaults too when our sensors are disconnected. I use 000, and some guys over there are using 432. A huge difference.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #20 ·
Thanks Scarty,

I have moved on to the PCIII, worlds apart. The Cobra is a fine product, but it was just never set the way I wanted it. The PCIII was a good move and I got it for $266.00, or about $60 over the cost of the Cobra.
 
1 - 20 of 21 Posts
Top