M109 Rider Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
I just installed my Cobra FI2000 last night. I left it programmed in the default setting, any recommended settings? I have K&N filters and I removed the baffle from my stock exhaust. I didn't get a chance to ride it last night since it was kinda late. I did fire it up and didn't observe any abnormal conditions. I hope the Cobra helps this beast get better gas mileage and stops some of the hesitation.

Thanks,

Mike
 

·
Registered
Joined
·
146 Posts
options

A JSD-3M does wornders on these bikes also. My bike has K&N's with scorpion tips also a Cobra tuner. I started off with stock settings and it ran fine and bumped it up a little at a time. Before I did those mods i did the JSD-3M and it reall smooths out the bike.
 

·
Registered
Joined
·
5,843 Posts
Since most of there "tuners" allow you to richen the mixture for performance pipes and filters, don't expect to get better mileage. Richening the mixture does not equal better mileage. Expect it to go down several mpg.

If you were concerned about mileage, you bought the wrong bike. Its kind of like buying a Ford Lightning and complaining when it gets 12mpg. You don't buy a truck with a Roots-blown V-8 for mileage. I know, I have one!:D
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #6 ·
I tried the stock setting but my bike is still sputtering when taking off from a light or stop. I feels like it is misfiring....I twist the throttle and here popping...


Mike
 

·
Registered
Joined
·
16,261 Posts
I tried the stock setting but my bike is still sputtering when taking off from a light or stop. I feels like it is misfiring....I twist the throttle and here popping...

Mike
Was it doing this before the install? If so, something else is wrong. If not, are you sure you have the connectors plugged in all the way on the injectors and harness?
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #8 ·
Was it doing this before the install? If so, something else is wrong. If not, are you sure you have the connectors plugged in all the way on the injectors and harness?
It wasn't doing this prior to the Cobra install. I went back and double checked all connections.
 

·
Registered
Joined
·
2,263 Posts
Start over

Remove the Cobra unit and see if it stops doing this. My bet is it still will. Sounds like a clogged fuel filter to me. Ever change yours?
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #10 ·
Remove the Cobra unit and see if it stops doing this. My bet is it still will. Sounds like a clogged fuel filter to me. Ever change yours?
I have never changed the fuel filter. I bought the bike with 1500 miles on it, I have 5500 now. Do you have the instructions on how to change the fuel filter?

Mike
 

·
Registered
Joined
·
1,172 Posts
I guess our first question should be - "what mileage are you getting?" - I think if you do a search on here for mileage, most of us are getting high 30's to high 40's mpg depending how the bike is riden, I can ride my bike hard and still get 32-33.... I just did 344 miles yesterday and I keep track of every mile, I was running 70 - 85 most of the time and I got 41.7 for the day...If your in the range then mileage isn't a question.
I have k&n's and jsd3m auto and hogged of pipes - my fi2000r setting are 2.5,4,2.....
hope this helps - good luck and ride safe
 

·
Registered
Joined
·
16,261 Posts

·
Registered
Joined
·
216 Posts
OH YA I `LL BET HE NEEDS TO REPLACE THAT FILTER. I DID MINE AT AROUND 3000 MILES LOOKED OK BUT WHEN YOU CUT THE FILER COVER OFF AND SEE WHATS INSIDE YOU WILL UNDERSTAND. I HAVE ABOUT 10K ON MY 06 AND REPLACE IT ABOUT 2-3 TIMES BY NOW, BIT PRICEY FOR THOSE LITTLE FILTERS BUT WHAT A IMPROVEMENT IN THE PERFORMANCE. BUT I ALSO THINK THERE MAY BE SOME OTHER ISSUES GOING ON THERE TOO.....GOOD LUCK AND REPLACE THAT FILTER :cop: TRY TURNING UP THE FIRST POT TO AT LEAST 2.5 TO 3 AND TRY IT
 

·
Registered
Joined
·
5,843 Posts
I have never changed the fuel filter. I bought the bike with 1500 miles on it, I have 5500 now. Do you have the instructions on how to change the fuel filter?

Mike
That fuel filter is not going to be a problem at your mileage. It may or may not be a problem at all. I have a friend who has a nine with near my mileage, 14,000. His has not been changed, mine needed changing at around 11,000.
 

·
Registered
Joined
·
24 Posts
I guess our first question should be - "what mileage are you getting?" - I think if you do a search on here for mileage, most of us are getting high 30's to high 40's mpg depending how the bike is riden, I can ride my bike hard and still get 32-33.... I just did 344 miles yesterday and I keep track of every mile, I was running 70 - 85 most of the time and I got 41.7 for the day...If your in the range then mileage isn't a question.
I have k&n's and jsd3m auto and hogged of pipes - my fi2000r setting are 2.5,4,2.....
hope this helps - good luck and ride safe
I am getting 25.7 MPG and have the FI2000
I have Cobra Swept with the baffles, blocked off the backing of my "hot air" intakes with the Holly screen and foam, + the FI 2000. How is anyone getting 45 mpg? I do not always ride her like I stole her. But I have NEVER seen 35 nor 40 nor 45 EVER. Almost want to call you a lier are numbers are so far off !!! What am I doing wrong?

Mitchell
 

·
Registered
2009 / VZR1800
Joined
·
3,517 Posts
I am getting 25.7 MPG and have the FI2000
I have Cobra Swept with the baffles, blocked off the backing of my "hot air" intakes with the Holly screen and foam, + the FI 2000. How is anyone getting 45 mpg? I do not always ride her like I stole her. But I have NEVER seen 35 nor 40 nor 45 EVER. Almost want to call you a lier are numbers are so far off !!! What am I doing wrong?

Mitchell
Is the way you calculate your mileage correct?.. Not to be a smart "donkey" here, but there is probably something wrong with your formula.... Km/miles, Us gallon/ "Canadian" gallon,.. and the litres.... How many Km you get per litre??
 

·
Registered
Joined
·
9 Posts
Mileage and FI2000

Hi,

I have gotten n the 40's on my 9. and my formula is mile/gallons.
I had to have m actuator changed now I need to reset my fi.
I have cobra swept pipes, anyone have the same and what are your setting?
I can not find my manual anymore
 
1 - 18 of 18 Posts
Top