M109 Rider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter · #1 ·
Today I was cleaning my bike and noticed the heat shield on the front cylinder was loose. With a little investigation i realized the welded on hose clamp bracket had broken off. Has anyone had this problem. Upon removing the heat shield i did notice the pipe was almost all gold in color. Perhaps the pipe is getting too hot? Thanks for the help.

fish
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #5 ·
Anybody have any ideal about getting the heatshield bracket fixed by Cobra or should i see if a welding shop can fix it instead. I live 30 minutes from Cobra so i am hoping i can drop it off.
 

·
Registered
Joined
·
123 Posts
Anybody have any ideal about getting the heatshield bracket fixed by Cobra or should i see if a welding shop can fix it instead. I live 30 minutes from Cobra so i am hoping i can drop it off.
Looks like it' somewhat common to have that bracket come loose. Mine too. I think welding it back on will damage the chrome. No? Did you get yours fixed?
Thanks
 

·
Registered
Joined
·
1,420 Posts
Mine did the same thing (November 2011) only I had the Cobra Swepts. Cobra honored their warranty but only because a dealer installed them! They came loose again! I installed Hard Krome Sideburners and never looked back. I'll never spend my money with Cobra again. Never.

http://www.m109riders.com/forums/showthread.php?t=149984
 

·
Registered
Joined
·
244 Posts
I've got the dragsters but my brackets are holding tight. The pipe discoloration is completely normal. It is just the steel oxidizing at various exhaust temperatures. The whole purpose of the chrome plated heat shield is to hide the discoloration. Nothing to worry about!
 
1 - 8 of 8 Posts
Top