M109 Rider Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
378 Posts
Discussion Starter · #1 ·
Just got my bike out of the shop last sat, went fora nice ride, to my suprized My new gen CLA light( Yea the one with 150 leds) had quit a few lights blown. What the F:edit:ck, They need to really find a better maker of these because this is getting rediculious.. Regaurdless of the exchange it is still a pain in the butt. Has anyone else had any promblems with the new gen? Also installed the relay from lights4tails and it worked great. Oyea, the 250 dunny handles great, took some ride on the twistes going up Rt. 20 in Dixion, IL handles well for a big bike. BY the way its amzaing that my turn signals leds didnt blow wouldn't they be underthe same vibration as the rear. i guess i should call Frank at CLA and say hey just offer a SOILD clear brake light and under tail signals...


"I think I have found my soulmate" :clap2:
 

·
Registered
Joined
·
356 Posts
Wife has been running the new CA light for almost a year with no issues. However, I just bought a clear tail light off of ebay for real cheap and like it more than the wife's CA. If you don't want to run the turn signals, just don't hook them up and you will still have the brake light and tail light.:bigthumbsup: Good luck with your next one.:D
 

·
Registered
Joined
·
1,746 Posts
get OEM

I'm glad I bought a clear OEM light. I was looking at the CA light initially, but that was when they first recalled them. I didn't want to splice wires anyway.
 

·
Registered
Joined
·
643 Posts
Haven't had any issues with my newest CA taillight, its been on since October of 09. However, I did't install the resistor. I'm the furthest thing from an electrician, so I have no idea if that has any bearing on thelighting issue you are having.

I just liked the faster blink rate to be more observant to the idiots on cell phones behind me.....

If I run into any issues this summer, I will post them. Otherwise, the newest light has been great so far (knock on wood).
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #6 ·
Reply

Well dgk1979, if yours havent went out in Chi i must have gottton a bad one because i know thosstreets are bad up there....lol But for real I hope i just got a bad one because it really brings the bike out. Frank at CAL said he would send me one today, so I would not have top send mine in untill I get the replacement. Very cool guy to work with I just wish they would geta better mfg of these lights. I dont think the relay would cause the promblem, it only slows it down. My other turn signals are leds and they work fine.
 

·
Registered
Joined
·
1,764 Posts
if nothing else, the customer service is great. these guys have made up alot of lights trying to make things right. if i didnt have the LE i would give them a try.:bigthumbsup:
 

·
Radio Active Member
Joined
·
22,679 Posts
After all the bad press that has been given to these guys over the last couple years, I'm surprised anyone still orders from them. Great customer service is nice, but it would be better if they just made a light that worked.

Glad I have an OEM LE light too, even if it doesn't have the integrated turns.
 

·
Registered
Joined
·
91 Posts
Mine lasted about 3 months till half of the red LED's went out. They offered me a replacement but.... I think I will stay with the stock light. The CA is just not as bright as I would like. I may just get the replacement and sell it on ebay.
 

·
Registered
Joined
·
1,457 Posts
Well dgk1979, if yours havent went out in Chi i must have gottton a bad one because i know thosstreets are bad up there....lol But for real I hope i just got a bad one because it really brings the bike out. Frank at CAL said he would send me one today, so I would not have top send mine in untill I get the replacement. Very cool guy to work with I just wish they would geta better mfg of these lights. I dont think the relay would cause the promblem, it only slows it down. My other turn signals are leds and they work fine.
Didn't the new flasher take care of not having to use the resisters for the turn signals?
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #11 ·
Yes

Yes they took care of the fast flash rate and you dont have to worry about splicing wires, just pug and play.
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #13 ·
5mth?

Hey tyler depending on were your at have you had time to really ride with the new light on? Im in the midwest and riding season is just starting for us had mine for 3mths but just rode on it last sat and lost lights already
 

·
Registered
Joined
·
480 Posts
I am in orlando florida. We ride year round down here. Actually the winter is probably the best riding. I ride to work just about everyday of the week.
 

·
Registered
Joined
·
5,799 Posts
I had a first generation that went bad after about one year. Traded it for a second generation, which lasted about one year. In both instances, the directional signals went out on one side only. This time I just unplugged them, and I still have the brake light and tail light function two years later.

I still have my stock signals, re-located to the reflector brackets anyhow. I am happy so far.
 
1 - 15 of 15 Posts
Top