M109 Rider Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
Hello all,

I have been noticing that when I am taking off the bike seems to sputter when going through the gears, mostly 2nd and 3rd. Once I am cruising around it doesn't happen, only when I'm really getting on it.

I have tried changing the plugs and that didn't help. Any help to maybe find what might be causing this ??
 

·
Registered
Joined
·
285 Posts
It could be that mesh fuel filter inside the tank. There is a fantastic video on how to change it, if you do a search for it you will find it.
 

·
Radio Active Member
Joined
·
27,669 Posts
It could be that mesh fuel filter inside the tank. There is a fantastic video on how to change it, if you do a search for it you will find it.
That could be it. How many miles and what year bike do you have? It seems to solve a lot of problems.
 

·
Registered
Joined
·
918 Posts
your not hitting the rev limiter are you? :dontknow:

I have been noticing that when I am taking off the bike seems to sputter when going through the gears, mostly 2nd and 3rd. Once I am cruising around it doesn't happen, only when I'm really getting on it.
 

·
Registered
Joined
·
285 Posts
Yes thats the video. Be careful when placing the new filter on. I havent done mine yet but I have read extensively about it. I think you need to push it on and not twist it lest it snaps off. Please dont take my word for it, find out from someone who knows. The other guys that have responded to this thread are masters and can better advise you than me, I just know to be gentle with it.
 

·
Registered
Joined
·
3,234 Posts
If it is like the 7-11 down here there is your problem.... my mother bought gas there twice and I had to go get her truck both times... and put alot of additives in the gas to get it running....
 

·
Registered
Joined
·
5,844 Posts
Stop buying the crappy gas, buy it from one of the big names. I only use Shell (91) or Sinclair (93) when at home, but any of the big names are okay. Shell, Valero, Texaco, Chevron, etc.

Another thing I do, when I fill my Lightning, I also fill two five gallon cans. I keep these in the garage so I can top off my bike after riding. Itransfer the gas to a 2.5 gallon can fitted with a filter in the spout, then pour it in the bikes tank. You should see the filter in that spout after a year.

We shall see if that gets the new filter further down the road than the original.
 

·
Registered
Joined
·
5,844 Posts
It is not just about the name of the gas, but the age of the station.
And more appropriately, the age of the gas in the underground tank. You really need to buy premium from a station that sells a lot of it, as it tends to go bad if it sits to long. The Sinclair station I buy 93 from is the only game in town, and thus his does not have time to sit and go bad. He always has the tuners, vettes, stangs, camaros, Lightnings, etc., waiting for that stuff. He also shows me the test reports for his fuel, and the "93" shows on the report as 94.1.

If you are buyng "premium" from a 7-11, might as well just put 87 in there.
 

·
Registered
Joined
·
735 Posts
bad gas

It sounds a little early for me to go bad (the filter). But if you are getting crappy gas, it does not take long at all. You can always pull the tank and take a look at it.
That depends alot on where you buy your gas, I have a tendency to sticking to stations that have alot of traffic and usually buy from shell or BP. Cheap gas is exactly that! Cheap! You usuallly get what you pay for.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #15 ·
Hey everyone, I found what the problem was.

2nd gear on my bike is transmission is going out. The transmission was popping in and out of gear causing the feeling of sputtering.

Weird that a bike with less than 10K miles would be having transmission problems. Also I had a clutch cable snap on me at 4K miles. I do not ride hard on this bike so it is weird to see problems like this happen.

The shop I have been with for years contacted Suzuki and they said for a '07 it is too old to be covered under any kind of a warranty seeing as I am the 2nd owner. It sucks that I now have about 1700$ I need to pay someone before I can ride again. :verymad:
 

·
Registered
Joined
·
6,402 Posts
Hey everyone, I found what the problem was.

2nd gear on my bike is transmission is going out. The transmission was popping in and out of gear causing the feeling of sputtering.

Weird that a bike with less than 10K miles would be having transmission problems. Also I had a clutch cable snap on me at 4K miles. I do not ride hard on this bike so it is weird to see problems like this happen.

The shop I have been with for years contacted Suzuki and they said for a '07 it is too old to be covered under any kind of a warranty seeing as I am the 2nd owner. It sucks that I now have about 1700$ I need to pay someone before I can ride again. :verymad:
You can still ride. The bike has gobs of torque so start off in first, and go right to third.
 

·
Registered
Joined
·
285 Posts
I am so sorry to hear that. What a complete bummer.
 

·
Registered
Joined
·
1,722 Posts
:agree::agree::agree::agree::agree::agree::agree:
It could be that mesh fuel filter inside the tank. There is a fantastic video on how to change it, if you do a search for it you will find it.
 
1 - 18 of 18 Posts
Top