M109 Rider Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,035 Posts
Discussion Starter · #1 ·
Ok.. Since I put the bigair on my bike it seems to find the red line on the tach WAYYYYYYYYY too fast 8)

Anyone else with a non-stock intake setup have a similar issue? (not a bad one to have is it?) :evil:
 

·
Registered
Joined
·
1,035 Posts
Discussion Starter · #2 ·
Thats sick.. I almost got blown off the bike today already.. Looked down and I was at 135 on the speedo.. Rest of the guys had passed a slow moving vehicle on a 2-lane and I had to wait for traffic and a passing lane, buy the time I was clear to pass they were almost a half mile ahead of me.. Did NOT take long to run them down.. Had to tuck down behind the tank bag and hold on for dear life. LOVED IT! ehhe
 

·
Registered
Joined
·
1,592 Posts
That sounds all too familiar to me..nice isn't it. I'm just about to take the 109 out for it's first run (with other than a zero map in the PC3)..I just need to get some office work done, because the rest of the day will be history! :D
 

·
Registered
Joined
·
6,343 Posts
DaltonH said:
Ok.. Since I put the bigair on my bike it seems to find the red line on the tach WAYYYYYYYYY too fast 8)

Anyone else with a non-stock intake setup have a similar issue? (not a bad one to have is it?)  :evil:
Since the work I have done to my bike I have to be really carefull in first gear. The Rev limiter comes wayyyy fast. The rest I am ok...

I think it's
1) because it hits it real fast
2) Because I am bz trying NOT to spin the tire, and NOT to pull the front wheel.

Definatley a good problem to have! :evil:
 

·
Registered
Joined
·
244 Posts
Have a UltraFlow intake system, PCIII, Drilled Pipes, and JR's map and I'm having the same problem. Unbelievable difference!! :bigthumbsup:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top