M109 Rider Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
First, let me just say  :mad: :mad: :mad:

With that out of the way, I guess I'm joining those that were over-filled from the dealer... but once again, I'm confused  :confused:

A month ago, after riding the bike home from the dealer and around the loop a time or too (first 30 miles put on the bike), I check the air filter elements and oil level and all looked good so I thought I was one of the lucky ones whose dealer knew what they were doing...

BUT

Yesterday, with about 300 miles now on the bike, I noticed a bit of oil dripping from the left air filter.  This morning I rode another 15  miles in to work and I had oil blown down the side of the element, onto the key and other fascia there... luckily nothing on me  ;)  But is it possible the oil spontaneously generated?  Not likely, of course - so why didn't I have indications after the first 30 miles... and why did the oil level appear ok?  Only now to surface and rear it's ugly, oil-soaked head?

I called the dealer service dept. and at first they told me they were a week out for any open slots... then I mentioned "... this new M109R..." and suddenly they have an opening for tomorrow.  I do kinda like the way that worked out - but not sure of the coincidence.

Any thoughts?

J
 

·
M109Riders Founder
Joined
·
8,014 Posts
I rode home about 30 miles and nothing showed up. It wasn't till I ran the bike a little harder for about 50 miles when my problem showed up. ::)
 

·
Registered
Joined
·
600 Posts
Mine didn't start bleeding 'til I got the rpms up a little - same with the coolant.



 

·
Registered
Joined
·
112 Posts
Mine also didn't show up until around the 100 mile mark. I thought i was cool too the first night I brought it home and had 35 miles on it. The dealer came and picked it up today. Your dealer should do the same thing. You shouldn't have to wait for an appontment for their screw up especially when your bike is inoperable. Then again, who's to say that this is all really the dealers fault. The bike is rather difficult to check the oil level and the factory checking procedure is just plain ridiculous.
I picked my bike up Friday and took today off to ride. My bike was picked up at noon and they just told me they are going to keep it overnight which really pisses me off. I guess it could be worse and I could be the dude with the antifreeze leak too. That's just unacceptable......as is this freakin oil problem! :verymad:
 

·
Registered
Joined
·
752 Posts
Dumb question. Could it be the rings seeding in so the blow by into your cylinders is lessened? After they seed in they are tighter and it backs up into your air box?
 

·
Registered
Joined
·
209 Posts
L-Train said:
Dumb question. Could it be the rings seeding in so the blow by into your cylinders is lessened? After they seed in they are tighter and it backs up into your air box?
I would think if that was the case you would have been makin blue smoke out of your exhaust from the blow by. But then again I'm not sure.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #7 ·
So I picked up my bike from the dealer service today... they had it 2 days  ::)  Said they couldn't get to it the first day.  I wasn't happy yesterday when they told me that, but let it slide...

Anywho... I wouldn't be exagerating when I say I fairly grilled the service mgr on how much oil he refilled with, what procedure he used, etc.  From what he said, and referring directly to the "odd" way to fill and check the oil, I felt comfortable enough he had it covered.  But he did concern me when he said he put 3200ml (about 3.5 qts as he compared it) in even though he admitted he didn't change the oil filter.  I told him the service manual said 3000ml when not changing the filter but he swore he checked, re-checked and double re-checked the level using the run/wait/check procedure and it checked ok each time.  I checked myself after the ride home and it *seems* fine... but then the level checked fine when I first got the bike, too, and I still have massive seepage out the air filter.

Thoughts, anyone?  3200ml/3.5qts sound right?

I also had them check the brakes since I was getting quite some noise (rear).  Nothing wrong there... no glazing, grooves, etc.  They emoried the surfaces but I still got some substantial squeak a couple times on the way home.  Chalk it up to the pad material, I guess  ::)

Oh, and on a separate note, I installed a spitfire windscreen tonight.  I ordered the 'smoked' version but think I still might lay some tint on it.  It''s "ok" - I need to do some minor tweaking and trim the mounts, but I'm happy to say my eyes no longer water at 110 anymore... Pics and details under a different thread when it's light out and I can take some shots.

J
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top