M109 Rider Forums banner

1 - 14 of 14 Posts
G

·
Discussion Starter · #1 ·
WOO HOO it's here....now only wish my bike was.

I've tried searching "TRE INstall" and a few other phrases....the instructions that came with it seem ok...but not having the bike here just kind of hard to "see" it...

My question is the connectors are the "triangle" looking ones...looking a lot like I remember one of the connectors on the Cobra Fi2000R I just installed

I assume this just plugs inline with that, or am I just totally off base...it does say to plug it in on the right hand side into the gear sensor connector...

either way can't wait to get this bad boy in after reading how this type of device seems to work wonders.....IF I actually remember to break out the camera I'll do my best at a "how to" since I don't seem to see one on any of the 9 sites.....

cheers!
 

·
Registered
Joined
·
2,909 Posts
WOO HOO it's here....now only wish my bike was.

I've tried searching "TRE INstall" and a few other phrases....the instructions that came with it seem ok...but not having the bike here just kind of hard to "see" it...

My question is the connectors are the "triangle" looking ones...looking a lot like I remember one of the connectors on the Cobra Fi2000R I just installed

I assume this just plugs inline with that, or am I just totally off base...it does say to plug it in on the right hand side into the gear sensor connector...

either way can't wait to get this bad boy in after reading how this type of device seems to work wonders.....IF I actually remember to break out the camera I'll do my best at a "how to" since I don't seem to see one on any of the 9 sites.....

cheers!
:congrats:; That is definitely one of my next Mods and a "How-to Step-by-Step is a MUST if one is not available.

I know some members had issues having to wait for this product after placing their order; I am just curious to know how long did you have to wait to receive it after placing payment? I have not seen these on e-Bay lately so I figured they must not be making them anymore, but I was just able to access their direct website and they are advertised there, I might get it thru there.
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,878 Posts
Go down to post #8 by jeffw in this thread and follow the pictures. Make sure the plug you attach it to has a pink wire in it. There's two of them that it can plug into, but only one works. The wire you need is the gear position wire and it's sometimes tucked behind the frame down tube.

It just plugs inline. You unhook the connector and plug this inline with it.

http://www.m109riders.com/forums/showthread.php?t=83184
 

·
Registered
Joined
·
1,457 Posts
Go down to post #8 by jeffw in this thread and follow the pictures. Make sure the plug you attach it to has a pink wire in it. There's two of them that it can plug into, but only one works. The wire you need is the gear position wire and it's sometimes tucked behind the frame down tube.

It just plugs inline. You unhook the connector and plug this inline with it.

http://www.m109riders.com/forums/showthread.php?t=83184
ZOOM you are quick on the trigger!!!!!
 
G

·
Discussion Starter · #6 ·
I ordered it a day before heading down to OBX bike week..and it got here a couple days ago...I ordered from their website...when I get home i'll snap a pic...looks very well made...

all in all order to delivery took bout 2 weeks....longer than some, not as long as others...Just sent normal post office mail so...obviously that caused the normal us mail delay

:congrats:; That is definitely one of my next Mods and a "How-to Step-by-Step is a MUST if one is not available.

I know some members had issues having to wait for this product after placing their order; I am just curious to know how long did you have to wait to receive it after placing payment? I have not seen these on e-Bay lately so I figured they must not be making them anymore, but I was just able to access their direct website and they are advertised there, I might get it thru there.
 
G

·
Discussion Starter · #7 ·
Go down to post #8 by jeffw in this thread and follow the pictures. Make sure the plug you attach it to has a pink wire in it. There's two of them that it can plug into, but only one works. The wire you need is the gear position wire and it's sometimes tucked behind the frame down tube.

It just plugs inline. You unhook the connector and plug this inline with it.

http://www.m109riders.com/forums/showthread.php?t=83184
sweet thanks...that's pretty much what the instructions "say", just always nice to verify with a picture.....
 

·
Registered
Joined
·
497 Posts
i ordered mine last sunday and it was in the mail friday when i got home installed today and man what a differance :D:D
 

·
Registered
Joined
·
2,909 Posts
i ordered mine last sunday and it was in the mail friday when i got home installed today and man what a differance :D:D
Do you really notice a Big difference??? I ordered mine last Friday and I just got it yesterday, have not installed it yet but will probably do the install tonight. How hard was it to get to the GPS? Is it right behing the right side cover and easy to get to?

Also, I noticed that it has some tabs for just in case you want to hold it in place with screws; did you leave it loose in there or did you hold it in place with something else? I was thinking about probably using some velcro:dontknow:.
 

·
Registered
Joined
·
2,703 Posts
Do you really notice a Big difference??? I ordered mine last Friday and I just got it yesterday, have not installed it yet but will probably do the install tonight. How hard was it to get to the GPS? Is it right behing the right side cover and easy to get to?

Also, I noticed that it has some tabs for just in case you want to hold it in place with screws; did you leave it loose in there or did you hold it in place with something else? I was thinking about probably using some velcro:dontknow:.
Mine is hanging loose and I have had no problems with it.
 

·
Registered
Joined
·
497 Posts
pull the right side cover
here is a pic of what your looking for
http://www.jsdproducts.com/m109/109-install-4.jpg
i used 2 sided tape and mounted it right on the metal post
and yes made a big differance i used to idle through town and it felt like it was missing and sometimes a small back fire and thats all gone now best 5 min. install ever
 

·
Registered
Joined
·
2,909 Posts
pull the right side cover
here is a pic of what your looking for
http://www.jsdproducts.com/m109/109-install-4.jpg
i used 2 sided tape and mounted it right on the metal post
and yes made a big differance i used to idle through town and it felt like it was missing and sometimes a small back fire and thats all gone now best 5 min. install ever

Thanks, I guess you posted your reply as I was doing the install. I found the plug and it took me about 10 minutes, however, that was including the "beer breaks" and taking the dogs to handle their business. I guess the velcro or double-stick tape will have to wait since the velcro I have does not contain any adhesive and I knew I didn't have any double-stick tape. I don't think it'll rattle that much since there isn't a lot of play the way I placed it. I will know tomorrow if I notice that there is any difference and will keep you guys/gals posted:bigthumbsup:.

While I have never been mechanically inclined, I believe that doing all this little mods myself has lit a new interest. I guess now I am ready to verify that all "eight injectors" are firing the right amount of electricity:joke:.
 

·
Registered
Joined
·
497 Posts
tre

Thanks, I guess you posted your reply as I was doing the install. I found the plug and it took me about 10 minutes, however, that was including the "beer breaks" and taking the dogs to handle their business. I guess the velcro or double-stick tape will have to wait since the velcro I have does not contain any adhesive and I knew I didn't have any double-stick tape. I don't think it'll rattle that much since there isn't a lot of play the way I placed it. I will know tomorrow if I notice that there is any difference and will keep you guys/gals posted:bigthumbsup:.

While I have never been mechanically inclined, I believe that doing all this little mods myself has lit a new interest. I guess now I am ready to verify that all "eight injectors" are firing the right amount of electricity:joke:.
let me know how you like it
 

·
Radio Active Member
2007 Candy Sonoma Red
Joined
·
22,878 Posts
Do you really notice a Big difference??? I ordered mine last Friday and I just got it yesterday, have not installed it yet but will probably do the install tonight. How hard was it to get to the GPS? Is it right behing the right side cover and easy to get to?

Also, I noticed that it has some tabs for just in case you want to hold it in place with screws; did you leave it loose in there or did you hold it in place with something else? I was thinking about probably using some velcro:dontknow:.
Duende, look at the thread I linked above. It has all of what you need, and it takes maybe 10 minutes to install. There's two connectors it can plug into but one goes to the speedometer. The thread tells you where the connector is and to use the one with the pink wire in it.
 
1 - 14 of 14 Posts
Top