M109 Rider Forums banner
21 - 40 of 67 Posts

·
Registered
Joined
·
5,511 Posts
here's the 300 Metz ..... had to shave down the side of the tire on the shaft side to fit ..... still rubbed and didnt roll with the air ride all the way down ...

run the avon now and with a little more time into the fender the avon goes on and rolls when air ride is all the way down ..

 

·
Registered
Joined
·
1,384 Posts
I'm running a metz 300mm with no problem at all .. with all the cutting needed and running a SWAPM WORKS SWINGARM .. The only thing I done was add a 16th inch washer on the drive side and then shave down the down under brake bracket where the caliper mounts to .. to alow the proper alignment ........... :bigthumbsup:....On the avon 300 is a much smaller sidewall ...........
 

·
Registered
Joined
·
164 Posts
I'm also running a swamp works swing arm and a Metz 300 with a stock widened rim and arnott air ride. Let me know if you need any advice or have questions on the install. I ran into a lot of problems with mine but have almost all the bugs worked out.
 

·
Registered
Joined
·
157 Posts
I'm running a metz 300mm with no problem at all .. with all the cutting needed and running a SWAPM WORKS SWINGARM .. The only thing I done was add a 16th inch washer on the drive side and then shave down the down under brake bracket where the caliper mounts to .. to alow the proper alignment ........... :bigthumbsup:....On the avon 300 is a much smaller sidewall ...........
Did you use the washer with the spacers they supplied? I was given a long spacer to slide into hub and a short one for the caliper side but tire is still rubbing. I have a 300 metzler on 10.5" wheel.
 

·
Registered
Joined
·
3,004 Posts
Did you use the washer with the spacers they supplied? I was given a long spacer to slide into hub and a short one for the caliper side but tire is still rubbing. I have a 300 metzler on 10.5" wheel.
Not sure if I ever heard of anyone using a 10.5" wheel. My Cycle House swingarm had to be notched so that my Metzeler tire would not rub. I ended up notching both sides of the arm.
 

·
Registered
Joined
·
3,004 Posts
I have the swamp works 2 piece and Dave from swampworks told me others have my setup and it works.
If they say it works it must.:D Maybe someone with a 10.5" wheel will speak up. I just do not know of anyone. Which side is rubbing? If you are using the supplied spacers and it is still rubbing, then you have to shim some more or you better break out the sandpaper.
 
21 - 40 of 67 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top