M109 Rider Forums banner

ignition

  1. M109R Shop Talk
    Hi All, I haven't been here for a long while and I've long since sold my very cool 2007 SE (Blue and White!). I've had a Vulcan 1700, then a Raider and currently a 2013 Vaquero (lowered, 21" front wheel, mini apes with internal wiring, Vance and Hines 2 into 1, PC 5, Big Air) and like you...
  2. M109R Shop Talk
    Hi guys I am going nuts with this issue again, I have done everything I could think of us and nada. Spark plugs checked. Less than 3k KM and cleaned them up. Just had a little black soot over the ignitions. Battery was over a year still running good but I changed for a new one, it shouldn't...
  3. M109R Shop Talk
    Hey guys, first post here.. So the other day while I parked at gas station I came out and my bike would not start. It made a spark/short kind of noise and everything went dead. No cluster lights no power whatsoever... Only way to get the bike to get power back is to disconnect the battery then...
  4. M109R Shop Talk
    Hi guys! Long time without posting here. After 2 years of enjoying my beautiful bike I have encountered a little problem. Since 1 image (a video in this case) is worth 1000 words, I rather show you the weird noise my bike is doing when I switch it on. Actually, It doesn't turn on at all...
  5. M109R Shop Talk
    Hello all, I need your expert help again! Thank you in advance to everyone that helps out!! I lost my key about a week ago. At first I thought not a big deal, my bike cake with a spare. Turns out the spare is a blank. I went to the dealer to see if they could help and was told there is nothing...
Top