service problems?
Results 1 to 6 of 6

Thread: service problems?

  1. #1
    Active Member
    Join Date
    Apr 2006
    Posts
    53

    Default service problems?

    Has anyone had any problems with their 109r yet? I have only had mine for 1 week and it has already been in the shop twice. The FI light keeps coming on. The first time the tech said it was an exhaust control module valve. He said the cable was never tighten good from delivery and setup. Then it came on again and it has been in the shop ever since. Go figure it goes in the shop on a beautiful weekend. Any info would be great.

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    toneout
    Guest

    Default Re: service problems?

    What's it in the shop for the second time?

  4. #3
    M109Riders Founder Lamonster's Avatar
    Join Date
    Apr 2006
    Location
    Springfield MO
    Posts
    8,014

    Default Re: service problems?

    Quote Originally Posted by toneout
    What's it in the shop for the second time?
    Has anyone had any problems with their 109r yet? I have only had mine for 1 week and it has already been in the shop twice. The FI light keeps coming on. The first time the tech said it was an exhaust control module valve. He said the cable was never tighten good from delivery and setup. Then it came on again and it has been in the shop ever since. Go figure it goes in the shop on a beautiful weekend. Any info would be great.

    Bummer

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Active Member
    Join Date
    Apr 2006
    Posts
    53

    Default Re: service problems?

    my m109r is in the shop for replacing the exhaust control valve. It is faulty and they have to order a new one from the factory. It has been in the shop for a week and the part hasn't even been ordered because they say they can't find the order number from suzuki. Suzuki doesn't have the parts list for the bike in the dealership near me. The dealer said it could be weeks before they get the part. In the mean time it just sits in the shop. Very frustrated owner

  7. #5

    Default Re: service problems?

    I would be pissed. They should compensate you with something for the trouble.

  8. #6
    Active Member
    Join Date
    Apr 2006
    Posts
    74

    Default Re: service problems?

    shawnadair was it the valve itself or the electronics that open and close it. the module was bad on mine and they got a part from Canada in 5 days. It was making the fi light come on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •