Engine died out while riding
Results 1 to 6 of 6

Thread: Engine died out while riding

  1. #1

    Default Engine died out while riding

    Engine stopped while riding in New Hampshire. Turn on kill switch no fuel pump or bike don’t turn over at all . I bypass the pump and it’s working. Checked my Solenoid relay and it’s working. My battery is good also. Bike lights turn on and dash is working fine. But the bike doesn’t turn on no single to let the bike crank over and pump is not turning on. Check with wire for FI code not showing no errors or C00 at all please help .

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2

    Default

    Fuel is flashing like it’s empty but had fuel
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	E74A216D-FA02-456F-BDB8-7C4F8F7EEA17_1602207987782.jpg 
Views:	11 
Size:	34.4 KB 
ID:	389840  

  4. #3
    Very Active Member supergez's Avatar
    Join Date
    May 2007
    Location
    Wollongong Australia
    Posts
    115

    Default Fuel pump.

    Quote Originally Posted by Lou M109r View Post
    Fuel is flashing like it’s empty but had fuel

    Have you had the tank off lately , sometimes the little yellow wire comes loose in the brown plug at the rear of the tank and the pump won't run, just a thought.

    Good luck,

    Gez.
    1 De/sticker .<br />2Iso grips throttle boss x 2 red accent rings.<br />3Engine bars<br />4Drive shaft cover.<br />5# Plate (Gez 09) chrome<br />6Exhaust ( baffles ) modded. <br />7Chrome side mount rego holder.<br />8Tank bra <br />9Jsd-3m<br />10Polished M109R res cover<br />11Smoke Indicator Lenses.<br />12Stebel horn &nbsp;right cover).<br />13Suzuki backrest and rack.<br />14Widow pegs <br />15Polished M109R engine cover.<br />16Blueant Inter .<br />17Nokia 6110 nav phone.<br />18Home made rad grille suz +&#39;s&#39;.<br />19) Braided brake lines.<br />20KN filters/modded holleys.<br />21Elite 3 250 f/b<br />22KM tach <br />23Swing arm cover<br />24pc3 /rc mods<br />25c/f gel seats<br />26bc clutch

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Very Active Member 06MrMike's Avatar
    Join Date
    Jun 2006
    Location
    Westmore, VT
    Posts
    536

    Default

    check the kick stand switch, clutch switch and the wire that can come loose under the tank......

  7. #5
    Very Active Member
    Join Date
    Jun 2012
    Location
    Detroit
    Posts
    358

    Default

    Have a look at your ignition coils.

  8. #6

    Default

    The fuel pump is good bypassed it and was working .the coils are good check them with a Multi reader . When I got to the tip over sensor with the multi reader the to sensor if not working. I ordered A TO sensor on eBay let you guys when I get it running

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->