Throttle Sputter / Poor Response / Fuel Issue / Fuel Pump / Fuel Filter
Results 1 to 6 of 6

Thread: Throttle Sputter / Poor Response / Fuel Issue / Fuel Pump / Fuel Filter

  1. #1
    Member
    Join Date
    Apr 2009
    Location
    Colorado
    Posts
    20

    Talking Throttle Sputter / Poor Response / Fuel Issue / Fuel Pump / Fuel Filter

    Wanted to thank everyone out there for all the good information regarding this topic. Never would have thought about taking the ignition off and removing the back cover to see if the plastic piece inside is cracked causing an issue only at a certain rpm. Also saw the posts about checking the connection from the Now to what my was / is doing. First I thought it was a dirty fuel filter. Sputtering at 4K RPM in third gear. I was going to get to it eventually but trying to come home from work and she started to sputter above 2K rpm I knew I had to do something. I nursed it home and realized what riding a motorcycle like a normal person must feel like. :yikes: She has the power commander with cobra pipes and K&N air filters. Changed the spark plugs with the OEM plugs, cleaned and recharged the air filters and replaced the fuel pump and fuel filter. I though the Amazon Special for $65 fuel pump would do the trick. Well yes and no. I feel I have identified the problem but not completely solved it. She still has a sputter at 4500 - 5000 RPM in 3rd, 4th and 5th gear. Think my fuel pump is "you get what you pay for". Maybe the impeller is garbage or it would work great on a 750 or something but not the 9. Which brings me to my question thank you for hanging in there. I have seen the cost of just the fuel pump range anywhere from $250 to $375 and up.

    Does anyone out there had a good experience with where you purchased your fuel pump and might recommend a website?

    Thanks again and keep the shiny side up!

    :bigthumbsup:

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Member
    Join Date
    Apr 2009
    Location
    Colorado
    Posts
    20

    Default

    Does anyone out there had a good experience with where you purchased your fuel pump and might recommend a website?

  4. #3
    Very Active Member UVATom's Avatar
    Join Date
    Jun 2018
    Location
    Concord, VA
    Posts
    411

    Default

    Have you tried diagnosing using the service manual? I would think if the fuel pump was acting up it would give you a code of some sort. You might have to go into the dealer mode to get more info.

    OEM for $245

    http://www.oneidasuzuki.com/store/pa...r-2006-08.html
    Last edited by UVATom; 4 Weeks Ago at 06:26 PM.

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Member
    Join Date
    Apr 2009
    Location
    Colorado
    Posts
    20

    Default

    Quote Originally Posted by UVATom View Post
    Have you tried diagnosing using the service manual? I would think if the fuel pump was acting up it would give you a code of some sort. You might have to go into the dealer mode to get more info.

    OEM for $245

    http://www.oneidasuzuki.com/store/pa...r-2006-08.html
    Will double check everything using the Service Manual again. If if roll the throttle normal no issues it is only when I drop a gear and hammer the throttle or shift up and hammer the throttle i get the sputter at 4500 - 5000 RPM. Thanks for the link. Have always had really good luck with Oneida Suzuki.

  7. #5
    Member
    Join Date
    Apr 2009
    Location
    Colorado
    Posts
    20

    Default

    New Pump installed and I think it got better our that may just myself telling me it got better to make myself feel better. 4500-5000 rpm engine sputters once or twice and then will start pulling again above 5K rpm. Not sure there is a harmonic vibration causing something fishy to go on. Think I am going to raise the white flag and take it to a Dealer for a "check and advise"

  8. #6
    Very Active Member
    Join Date
    Jun 2012
    Location
    Detroit
    Posts
    366

    Default

    This sounds a lot like a problem I am having. Mine started out that way and then it became much worse. Now I twist the throttle and it coughs and spits like mad. I have the POD 300 with my PCV which was recording random drops to 0RPM while riding. Switched Power Commander - no help. Guy from Dynojet did remote hookup and he couldn't find the problem but verified the injector signal looked to be dropping out. I hooked up a cheap hand held oscilloscope ($40 Yeapook from Amazon) and sure enough there are random drops in the fuel injector firing signal. I will now be testing resistance of every wire in the harness. If I don't find something there I guess it's time for a new ECU.

    PS, go on YouTube and find out how to put it in dealer mode and check codes before looking at all the injector stuff. Make sure your plugs are all firing too. You could also run some Techron through it to make sure the injectors are clean and not clogged.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->