New wiring loom.
Results 1 to 5 of 5

Thread: New wiring loom.

  1. #1

    Default New wiring loom.

    Hi all, to cut a long story short some spud tried to steal my bike last year while I was working away. They cut through all the main wiring loom in order to try and bypass the alarm and immobiliser. Unfortunately my insurance had expired so I could not make a claim. I managed to get a new wiring harness from the US and have fitted it but I have UK bike and on the new wiring harness there are no connections for the Pair on the air box or the exhaust lambda connections. The bike now will not start. Do I need to order a new UK spec loom? Or is there anything else I can do? Any help greatly appreciated and I would be happy to pay anyone who could help me. Many thanks, Mark

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Very Active Member majalomalk's Avatar
    Join Date
    Feb 2017
    Location
    Birmingham england
    Posts
    156

    Default

    Personally i think you would need a uk loom as the wiring will be different.

  4. #3
    Very Active Member futurR's Avatar
    Join Date
    Jun 2006
    Location
    Indianapolis, Indiana
    Posts
    2,440

    Default

    Quote Originally Posted by Mark46 View Post
    Hi all, to cut a long story short some spud tried to steal my bike last year while I was working away. They cut through all the main wiring loom in order to try and bypass the alarm and immobiliser. Unfortunately my insurance had expired so I could not make a claim. I managed to get a new wiring harness from the US and have fitted it but I have UK bike and on the new wiring harness there are no connections for the Pair on the air box or the exhaust lambda connections. The bike now will not start. Do I need to order a new UK spec loom? Or is there anything else I can do? Any help greatly appreciated and I would be happy to pay anyone who could help me. Many thanks, Mark
    Are the UK keys chipped? I was never aware of there being an immobolizer on any versions. However, no US models have the O2 sensor/s(lambada), but we do have the Pair valve--- which could be different with the O2 involved.
    I am almost always working on a bike. If you have questions and need an answer quickly, just call me. 317-507-0940. Always up late. There will be time for sleep when I am dead!

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Active Member
    Join Date
    Mar 2015
    Location
    England
    Posts
    86

    Default

    Quote Originally Posted by futurR View Post
    Quote Originally Posted by Mark46 View Post
    Hi all, to cut a long story short some spud tried to steal my bike last year while I was working away. They cut through all the main wiring loom in order to try and bypass the alarm and immobiliser. Unfortunately my insurance had expired so I could not make a claim. I managed to get a new wiring harness from the US and have fitted it but I have UK bike and on the new wiring harness there are no connections for the Pair on the air box or the exhaust lambda connections. The bike now will not start. Do I need to order a new UK spec loom? Or is there anything else I can do? Any help greatly appreciated and I would be happy to pay anyone who could help me. Many thanks, Mark
    Are the UK keys chipped? I was never aware of there being an immobolizer on any versions. However, no US models have the O2 sensor/s(lambada), but we do have the Pair valve--- which could be different with the O2 involved.
    No UK bikes aren't chipped or alarmed/immobilised as standard so must be aftermarket.

  7. #5
    Very Active Member NoSetFine's Avatar
    Join Date
    Apr 2017
    Location
    Ontario, Canada
    Posts
    1,118

    Default

    Quote Originally Posted by Mark46 View Post
    Hi all, to cut a long story short some spud tried to steal my bike last year while I was working away. They cut through all the main wiring loom in order to try and bypass the alarm and immobiliser. Unfortunately my insurance had expired so I could not make a claim. I managed to get a new wiring harness from the US and have fitted it but I have UK bike and on the new wiring harness there are no connections for the Pair on the air box or the exhaust lambda connections. The bike now will not start. Do I need to order a new UK spec loom? Or is there anything else I can do? Any help greatly appreciated and I would be happy to pay anyone who could help me. Many thanks, Mark
    Hey Mark.
    Wow, that sounds like it would be a HUGE task! Congrats on making it this far - don't quit now!!
    I'm hoping the attached image helps, if not to fix your existing harness, then to clarify what's missing and you can decide from there.

    The 4 devices (and 2 connectors) I highlighted in RED are completely missing from the US version wiring.
    So your observations make sense - the second PAIR solenoid and O2.

    NOTE: The image file is too big (forum crushes it to the point of unreadable).
    You can use this DropBox link:
    https://www.dropbox.com/sh/db56dml6c...WF9KtJAha?dl=0

    Good luck.

    Click image for larger version. 

Name:	uk vs us PAIR O2 wiring.jpg 
Views:	17 
Size:	49.2 KB 
ID:	389762


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->