New to M109Rs - What is this for? Hiding under the rh cover?
Results 1 to 15 of 15

Thread: New to M109Rs - What is this for? Hiding under the rh cover?

  1. #1

    Default New to M109Rs - What is this for? Hiding under the rh cover?

    Hi
    My first post as I just bought my first M109R, in Canberra australia!

    I'm fixing the indicators (as they flash fast after 3 seconds even though they are not leds?), is this the flash unit in front of the battery? I want to replace it with an LED compatible one as all my indicators are broken and taped/glued up.

    Click image for larger version. 

Name:	IMG_0351.jpg 
Views:	184 
Size:	43.5 KB 
ID:	389320

    Also, when I removed the side covers, I noticed this unit on the side hanging by one cable tie? Is it something to do with the stock exhaust (I have aftermarket pipes?).

    Click image for larger version. 

Name:	IMG_0349.jpg 
Views:	127 
Size:	99.5 KB 
ID:	389316

    I also have to re-fit the stock pipes for registration as the new pipes are deep and loud and shoot flames which they won't like!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0351.jpg 
Views:	68 
Size:	90.1 KB 
ID:	389318  

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Active Member Fate9176's Avatar
    Join Date
    Jun 2020
    Location
    Holt, Michigan
    Posts
    53

    Default

    Quote Originally Posted by edz_M109r View Post
    Hi
    My first post as I just bought my first M109R, in Canberra australia!

    I'm fixing the indicators (as they flash fast after 3 seconds even though they are not leds?), is this the flash unit in front of the battery? I want to replace it with an LED compatible one as all my indicators are broken and taped/glued up.

    Click image for larger version. 

Name:	IMG_0351.jpg 
Views:	184 
Size:	43.5 KB 
ID:	389320

    Also, when I removed the side covers, I noticed this unit on the side hanging by one cable tie? Is it something to do with the stock exhaust (I have aftermarket pipes?).

    Click image for larger version. 

Name:	IMG_0349.jpg 
Views:	127 
Size:	99.5 KB 
ID:	389316

    I also have to re-fit the stock pipes for registration as the new pipes are deep and loud and shoot flames which they won't like!
    If your talking about that small black cable, it's probably the power to a tuner of some kind. I have the Cobra FI2000 powrpro black, and it has to be connected to the battery in the same way. Although my unit is located near the battery, looks like yours is under your tank. Maybe a power commander or something, not sure where they are mounted. It's definitely a power cable of some sort. The zip tie looks to be the servo motor. It is usually mounted on the exhaust. I would guess you have an aftermarket exhaust. You could just get a servo elimitator and remove that whole motor all together. I did the same thing when I upgraded to the freedom exhaust. If you don't have the motor left in, your FI light will come on, which is why most people just buy the eliminator so they can just throw that motor away. Atleast that is what I got from those pictures.
    "Life is what you make it..."


  4. #3
    Active Member Fate9176's Avatar
    Join Date
    Jun 2020
    Location
    Holt, Michigan
    Posts
    53

    Default

    It's kinda interesting they zip tied that motor on, the servo buddy is only like $50.

    https://www.amazon.com/Kawasaki-Suzu...5769133&sr=8-1

    This is what I got and works perfect.
    "Life is what you make it..."


  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Very Active Member Frotosride's Avatar
    Join Date
    Jun 2013
    Location
    GA
    Posts
    176

    Default

    Quote Originally Posted by edz_M109r View Post
    Hi
    My first post as I just bought my first M109R, in Canberra australia!

    I'm fixing the indicators (as they flash fast after 3 seconds even though they are not leds?), is this the flash unit in front of the battery? I want to replace it with an LED compatible one as all my indicators are broken and taped/glued up.

    Click image for larger version. 

Name:	IMG_0351.jpg 
Views:	184 
Size:	43.5 KB 
ID:	389320

    Also, when I removed the side covers, I noticed this unit on the side hanging by one cable tie? Is it something to do with the stock exhaust (I have aftermarket pipes?).

    Click image for larger version. 

Name:	IMG_0349.jpg 
Views:	127 
Size:	99.5 KB 
ID:	389316

    I also have to re-fit the stock pipes for registration as the new pipes are deep and loud and shoot flames which they won't like!
    The first pic there should be two relays one on the right side mounted horizontally and a larger on on the left mounted vertically. The one on the left is the flasher/kickstand safety switch (it's a multi function relay) you can just barely see the side of the relay in that pic. It is almost directly below the screw with the rubber cushion. If you do a search on the forum you will find tons of info and LED compatible flasher relays, fairly cheap at least in the states

    The second pic is defiantly your stock exhaust servo. Keep it, flash the ECM or get the eliminator are the only options. Just as Fate said, do not unplug and discard it.
    Last edited by Frotosride; 1 Week Ago at 01:03 AM.
    "Beat it like a red-headed Ford":
    '19 M9 '06 M9
    '09 commander
    '87 silverado on35's'87 c10 lwb(LS twin turbo sleeper project)'83 k20'83 k5 cucv 6.2 Detroit

  7. #5
    Very Active Member Frotosride's Avatar
    Join Date
    Jun 2013
    Location
    GA
    Posts
    176

    Default

    Oh and welcome to the forum but most importantly, welcome to the Beast!
    "Beat it like a red-headed Ford":
    '19 M9 '06 M9
    '09 commander
    '87 silverado on35's'87 c10 lwb(LS twin turbo sleeper project)'83 k20'83 k5 cucv 6.2 Detroit

  8. #6

    Default

    Quote Originally Posted by Frotosride View Post
    Oh and welcome to the forum but most importantly, welcome to the Beast!
    Thank you! Yes the key-tag on my bike is labeled 'Black Betty' by the previous owner which I think is an appropriate name.

    Yes, she does have aftermarket pipes so I will follow up on the eliminator. What does the exhaust servo motor actually do, never come across them before?

    I don't like the current pipes so I'm going to sell them and fit the cobra swept pipes, just have to decide on black or chrome. The current pipes spit flames I rev it a little but I'll have to quieten them or fit the standard pipes for rego i imagine. I'll put some restrictors in first and see how I go.

    That wire to the battery only goes to the earth, so I'll find out what it does when I remove the tank to fix the dent/scrape I put into it when I dropped it as it was coming off the box trailer.
    There is no wire to the positive post so not sure what they added. The PO's were obviously a bit rough in their work.

    This is the dent and my current pipes.
    Click image for larger version. 

Name:	Tank-dent-from-trailer-25-7-20-s.jpg 
Views:	25 
Size:	81.2 KB 
ID:	389404

    I suppose, I may as well get a ghost skull and flames at the same time if I'm fixing the dent.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Tank-dent-from-trailer-25-7-20-resize.jpg 
Views:	18 
Size:	46.1 KB 
ID:	389402  
    Last edited by edz_M109r; 1 Week Ago at 07:07 AM.

  9. #7
    Very Active Member thevili's Avatar
    Join Date
    Jan 2009
    Location
    Nitra, Slovakia
    Posts
    3,374

    Default

    [QUOTE=edz_M109r;4003354]Thank you! Yes the key-tag on my bike is labeled 'Black Betty' by the previous owner which I think is an appropriate name.

    Yes, she does have aftermarket pipes so I will follow up on the eliminator. What does the exhaust servo motor actually do, never come across them before?


    Read about it here:

    https://www.skutr.net/exhaust-valves...ors-explained/

  10. #8

    Default

    [QUOTE=thevili;4003356]
    Quote Originally Posted by edz_M109r View Post
    Thank you! Yes the key-tag on my bike is labeled 'Black Betty' by the previous owner which I think is an appropriate name.

    Yes, she does have aftermarket pipes so I will follow up on the eliminator. What does the exhaust servo motor actually do, never come across them before?


    Read about it here:

    https://www.skutr.net/exhaust-valves...ors-explained/
    Tah for that 'thevili', that's a great explanation. I'll have to chase one down, Amazon are out of them and ouch, they are $127 on ebay by the time you pay postage and gst.

  11. #9
    Very Active Member Frotosride's Avatar
    Join Date
    Jun 2013
    Location
    GA
    Posts
    176

    Default

    You can always get it flashed out of the ECM and a few other upgrades as well with the flash. I have mine in the exact same place on my BOSS because I'm waiting to get/fabricate a better intake and then get the flash from BCS.

    Pipes....go black!
    "Beat it like a red-headed Ford":
    '19 M9 '06 M9
    '09 commander
    '87 silverado on35's'87 c10 lwb(LS twin turbo sleeper project)'83 k20'83 k5 cucv 6.2 Detroit

  12. #10

    Default

    Quote Originally Posted by Frotosride View Post
    You can always get it flashed out of the ECM and a few other upgrades as well with the flash. I have mine in the exact same place on my BOSS because I'm waiting to get/fabricate a better intake and then get the flash from BCS.

    Pipes....go black!
    Absolutely, I'm going to sell of the old pipes and fit the black Cobra swept pipes, they look much better. Had them on my Honda Fury.

    Another question, when I removed the right-hand plastic side covers, mine has a little cylinder connecting the two 3 pin plugs, and a wire going off to earth? It's part of the cable that runs down into the bottom of the motor on the lower right, not sure what this either? My Yamaha has nothing like this.

    Also, I was refitting the standard pipes as part of making it quieter for rego and found one of the O2 sensor plugs unplugged behind the lefthand radiator cowl?

    Not sure what the PO has done? Any ideas? I would have thought at the very least you would have to wire in a resistor into it to stop triggering an error? Maybe I'll find one when I remove the tank to fit my heated grips?

    Click image for larger version. 

Name:	2-8-20-cables-1a.jpg 
Views:	22 
Size:	99.9 KB 
ID:	389430 Click image for larger version. 

Name:	2-8-20-cables-2b.jpg 
Views:	22 
Size:	71.3 KB 
ID:	389432

  13. #11
    Very Active Member Frotosride's Avatar
    Join Date
    Jun 2013
    Location
    GA
    Posts
    176

    Default

    I'm not real sure about the o2 sensor plug. We do not have any o2's on the bike. They are not standard options in the states. If it's unplugged then your fueling must be crappy. I doubt the PO tuned the sensor out of the ECM because you have the TRE(explained below) hard to believe the PO paid for a tune and didn't get it turned off.

    As for the pics, that little can is a TRE- timing retard eliminator. From the factory 1,2,3 gears have timing restarted to prevent full power. That little box tells the ECU that it's always in 4th gear and thus full power in all gears.
    "Beat it like a red-headed Ford":
    '19 M9 '06 M9
    '09 commander
    '87 silverado on35's'87 c10 lwb(LS twin turbo sleeper project)'83 k20'83 k5 cucv 6.2 Detroit

  14. #12

    Default

    Thanks for that info. Yes, I wondered if that was a TRE.

    The owner before the previous owner was obviously a bit dodgy. the PO didn't change anything, he just rode it.

    I'll wait till I get the new cobra black swept pipes before I get it tuned. Looks like ours are the California models, they come with oxygen sensor bungs.
    66 Mustang Convertible; DR650

  15. #13
    Active Member Stalker's Avatar
    Join Date
    Apr 2020
    Posts
    58

    Default

    Quote Originally Posted by edz_M109r View Post
    Thanks for that info. Yes, I wondered if that was a TRE.

    The owner before the previous owner was obviously a bit dodgy. the PO didn't change anything, he just rode it.

    I'll wait till I get the new cobra black swept pipes before I get it tuned. Looks like ours are the California models, they come with oxygen sensor bungs.
    There has been much debate on "Do Cali models have O2 sensors from factory" over the years.

    So far no one has ever come on here and actually validated that Cali models do indeed come with narrowband O2 from factory.

    If you think yours does please take photos when you change your exhaust and post them.

    Chances are that your North American M109R does not have O2 even if it is a Cali model.

  16. #14

    Default

    Sorry, just assumed they did. We definitely have in Aus and I was told Cal models did too. On my Honda Fury I just fitted a resistor to trick the O2 circuit into thinking they were fitted and it worked fine with the Cobra pipes with no sensors. illegal if someone checked at a registration inspection, but no-one ever does. They only do visual inspections in Australia.
    66 Mustang Convertible; DR650

  17. #15
    Very Active Member Frotosride's Avatar
    Join Date
    Jun 2013
    Location
    GA
    Posts
    176

    Default

    Quote Originally Posted by edz_M109r View Post
    Sorry, just assumed they did. We definitely have in Aus and I was told Cal models did too. On my Honda Fury I just fitted a resistor to trick the O2 circuit into thinking they were fitted and it worked fine with the Cobra pipes with no sensors. illegal if someone checked at a registration inspection, but no-one ever does. They only do visual inspections in Australia.
    Australia, you Definately have O2 sensors, had. Have you put any miles on the bike?
    "Beat it like a red-headed Ford":
    '19 M9 '06 M9
    '09 commander
    '87 silverado on35's'87 c10 lwb(LS twin turbo sleeper project)'83 k20'83 k5 cucv 6.2 Detroit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->